000031165 - SNMP queries and traps not working after configuring Authentication/Privacy passwords on Authentication Manager 8

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000031165
Applies ToRSA Product Set: SecurID
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.1, 8.1 SP1
Platform: Hardware Appliance, Virtual Appliance
Issue
  • SNMP receiver is not receiving the Authentication Manager traps, even after checking the configuration on both ends.
  • SNMP command line utilities snmpwalk, snmpget and snmptrap return "No Such Object available on this agent at this OID".
  • By checking the SNMP configuration file /etc/snmp/snmpd.conf, the proxy line is corrupted as shown below:
am81p:~ # cat /etc/snmp/snmpd.conf
###########################################################################
#
# snmpd.conf
#
#   - created by the snmpconf configuration program
#
###########################################################################
createUser snmp_f0cb53ds
rouser snmp_f0cb53ds noauth .1.3.6.1.4.1.2021
iquerySecName snmp_f0cb53ds
agentSecName snmp_f0cb53ds
###########################################################################
agentaddress 161
proxy -v 3 -u rsasnmp -l noAuthNoPriv 127.0.0.1:8002 .1.3.6.1.4.1.2197 proxy -v 3 -u secidnonprod -l
authPriv -a SHA -A 5M%;aPJ8T9proxy -v 3 -u secidnonprod -l authPriv -a SHA -A 5M%;aPJ8T9proxy -v 3 -u
secidnonprod -l authPriv -a SHA -A 5M%;aPJ8T9proxy -v 3 -u secidnonprod -l authPriv -a SHA -A
5M%;aPJ8T9proxy -v 3 -u secidnonprod -l authPriv -a SHA -A 5M%;aPJ8T9proxy -v 3 -u secidnonprod -l
authPriv -a SHA -A 5M%;aPJ8T9proxy -v 3 -u secidnonprod -l authPriv -a SHA -A 5M%;aPJ8T9proxy -v 3
-u secidnonprod -l authPriv -a SHA -A 5M%;aPJ8T9proxy -v 3 -u secidnonprod -l authPriv -a SHA -A
5M%;aPJ8T9proxy -v 3 -u secidnonprod -l authPriv -a SHA -A 5M%;aPJ8T9proxy -v 3 -u secidnonprod -l
authPriv -a SHA -A 5M%;aPJ8T9proxy -v 3 -a SHA -A authPassword -x DES -X privPassword -l authPriv
agentuser 127.0.0.1:8002 .1.3.6.1.4.1.2197DcEYRJGGjKBU;J -x DES -X 5dAADtHLwqUjqW8rxQJR$ 127.0.0.1:8002
.1.3.6.1.4.1.2197DcEYRJGGjKBU;J -x DES -X 5dAADtHLwqUjqW8rxQJR$ 127.0.0.1:8002 .1.3.6.1.4.1.2197DcEYRJGGjKBU;J
-x DES -X 5dAADtHLwqUjqW8rxQJR$ 127.0.0.1:8002 .1.3.6.1.4.1.2197DcEYRJGGjKBU;J -x DES -X 5dAADtHLwqUjqW8rxQJR$
127.0.0.1:8002 .1.3.6.1.4.1.2197DcEYRJGGjKBU;J -x DES -X 5dAADtHLwqUjqW8rxQJR$ 127.0.0.1:8002
.1.3.6.1.4.1.2197DcEYRJGGjKBU;J -x DES -X 5dAADtHLwqUjqW8rxQJR$ 127.0.0.1:8002 .1.3.6.1.4.1.2197DcEYRJGGjKBU;J
-x DES -X 5dAADtHLwqUjqW8rxQJR$ 127.0.0.1:8002 .1.3.6.1.4.1.2197DcEYRJGGjKBU;J -x DES -X 5dAADtHLwqUjqW8rxQJR$
127.0.0.1:8002 .1.3.6.1.4.1.2197DcEYRJGGjKBU;J -x DES -X 5dAADtHLwqUjqW8rxQJR$ 127.0.0.1:8002
.1.3.6.1.4.1.2197DcEYRJGGjKBU;J -x DES -X 5dAADtHLwqUjqW8rxQJR$ 127.0.0.1:8002 .1.3.6.1.4.1.2197DcEYRJGGjKBU;J
-x DES -X 5dAADtHLwqUjqW8rxQJR$ 127.0.0.1:8002 .1.3.6.1.4.1.2197
disk / 1%
load 100.01 100.02 100.03
#monitor -S -r 600 -o dskPath -o dskErrorMsg "disk free space below threshhold" dskErrorFlag != 0
#monitor -S -r 600 -o laNames -o laErrMessage "load above threshhold" laErrorFlag != 0
#monitor -S -r 600 -o memTotalFree -o memTotalReal "total free memory below threshhold" memTotalFree < 1024
#trapsess -v 3 -u remoteuser -a MD5 -A authPassword -x DES -X privPassword -l authPriv 1.2.3.4

  • The expected configuration file should look like the below:
am81p:~ # cat /etc/snmp/snmpd.conf
###########################################################################
#
# snmpd.conf
#
#   - created by the snmpconf configuration program
#
###########################################################################
createUser snmp_f0cb53ds
rouser snmp_f0cb53ds noauth .1.3.6.1.4.1.2021
iquerySecName snmp_f0cb53ds
agentSecName snmp_f0cb53ds
###########################################################################
agentaddress 162
proxy -v 3 -u snmpuser -l authNoPriv -a MD5 -A deRSAPwd% 127.0.0.1:8002 .1.3.6.1.4.1.2197
disk / 1%
load 100.01 100.02 100.03
#monitor -S -r 600 -o dskPath -o dskErrorMsg "disk free space below threshhold" dskErrorFlag != 0
#monitor -S -r 600 -o laNames -o laErrMessage "load above threshhold" laErrorFlag != 0
#monitor -S -r 600 -o memTotalFree -o memTotalReal "total free memory below threshhold" memTotalFree < 1024
#trapsess -v 3 -u remoteuser -a MD5 -A authPassword -x DES -X privPassword -l authPriv 1.2.3.4
CauseThe use of some characters in the SNMP Authentication Password or Privacy Password corrupt the snmpd.conf file. Below is a list of characters NOT to use in the Authentication Password or Privacy Password fields:
< > & % `
Resolution
  1. Open the Security Console > Setup > System Settings > Network Monitoring (SNMP)
  2. Select the Primary Server > Next
  3. Reconfigure SNMP using passwords that don't contain the following characters (< > & % `).
  4. Check the Apply the above settings to the replica instance(s) upon save.
  5. All snmpd.conf file will be recreated with the correct format
WorkaroundReconfigure SNMP using passwords that don't contain the following characters (< > & % `).

Attachments

    Outcomes