000030075 - Unable to install Token Software - Error: Token import failed

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 22, 2017
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Article Number000030075
Applies ToRSA SecurID Software Token 4.x
RSA SecurID Software Token 3.x
RSA SecurID Toolbar 1.x
Issue
  • Unable to import tokens to the RSA software
  • Error: "Token import failed. TKN library" 
  • Logs:

03-23-2015:11:14:52 Info Logging. : Open token database for write 
03-23-2015:11:14:52 Info Logging. : Unable to open token database
03-23-2015:11:14:52 Info Logging. : Open token database for write
03-23-2015:11:14:52 Info Logging. : Unable to open token database

 

 
Cause
  • The RSA Token software was not installed as admin the first time
  • When trying to re-install even as admin it will still case an error
  • the reason is that the database file needs to be deleted manually before reinstallation
Resolution
  1. Uninstall the RSA token software
  2. Manually delete:
    1. C:\ProgramData\RSA 
    2. C:\Users\<userId>\AppData\Local\RSA 
  3. Delete temp files
  4. Restart PC
  5. re-install RSA token software as admin

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