000030781 - Cannot download a file after protecting the web site with SecurID on Windows 2008R2

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000030781
Applies ToRSA Authentication Agent 7.1.3 build 128
IIS 7.5
Windows 2008 R2.
IssueRSA Authentication Agent 7.1.3 build 128
IIS 7.5
Windows 2008 R2
Customer protected the default web site on Windows 2008 R2. After the successful authentication, admin clicks on a link for downloading a file (web application).
The download fails with an error.
"Application download did not succeed. Check your network connection, or contact your system administrator or network service provider."
downloading shows below error in the logs:
+ Downloading http://casacramentocitest.my.muniservices.com/BizLINKClient/BLBizMGRClient.application?key=1dfc102a-0d16-4a96-8a6e-b07579d40d8a did not succeed.
+ The remote server returned an error: (500) Internal Server Error.
CauseRSAResponseInterceptorModule is interfering with URL processing by RSA Web Agent.
Resolution

A major source of interference with URL processing by our Web Agent can be eliminated in Agent build 168 by preventing the RSAResponseInterceptorModule from registering with IIS. To prevent this registration, and eliminate current registrations, one should do the following:
Contact RSA Security Technical Support to obtain RSA Authentication Agent 7.1.3 for Web build 168
A. In case of new installation:
1. Install RSA Authentication Agent 7.1.3 for Web build 168:


2. After installing, set the following registry value:
HKEY_LOCAL_MACHINE\SOFTWARE\SDTI\RSAWebAgent PreventInterceptorModuleManagement = 1 (REG_DWORD)
B. In case of upgrading currently installed Web Agent:
1. After upgrading original Web Agent installation to Web Agent build 168:
    From the WebSite's Agent configuration:
    -Disable the Web Agent (Follow by "iisreset")
2. Set the following registry value:
     HKEY_LOCAL_MACHINE\SOFTWARE\SDTI\RSAWebAgent PreventInterceptorModuleManagement = 1 (REG_DWORD)
3. Enable the Web Agent (Follow by "iisreset")

Attachments

    Outcomes