000029127 - Unable to install RSA Security Analytics Q2 Security Patch on 10.3.3 due to a duplicate glibc package

Document created by RSA Customer Support Employee on Jun 15, 2016Last modified by RSA Customer Support Employee on Apr 22, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000029127
Applies ToRSA Product Set: Security Analytics
RSA Product/Service Type: Core Appliance
RSA Version/Condition: 10.3.3
Platform: CentOS
O/S Version: 6
IssueWhen attempting to install the Security Analytics Q2 Security Update via yum, the following error message is observed:
Error: Package: glibc-common-2.12-1.132.el6.x86_64 (@nwupdates)
Requires: glibc = 2.12-1.132.el6
Removing: glibc-2.12-1.132.el6.i686 (@nwupdates)
  glibc = 2.12-1.132.el6
Updated by: glibc-2.12-1.132.el6_5.2.i686 (nwupdates)
  glibc = 2.12-1.132.el6_5.2
You could try using --skip-broken to work around the problem
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
glibc-common-2.12-1.132.el6_5.2.x86_64 is a duplicate with glibc-common-2.12-1.132.el6.x86_64
glibc-common-2.12-1.32.el6_5.2.x86_64 has missing requires of glibc = ('0', '2.12', '1.132.el6_5.2')

 The rpm -qa --qf "%{n}-%{arch}\n" | grep glib command results in the following output:
[root@hostname ~]# rpm -qa --qf "%{n}-%{arch}\n" | grep glib
glib2-x86_64
glibc-common-x86_64
glibc-i686
glibc-common-x86_64
dbus-glib-x86_64
glibc-x86_64

 
ResolutionTo resolve this issue, execute the command 
yum update glibc glibc-common
By executing th is command, glibc* will update only the two individual packages that are causing the problem.  Once these two packages  are updated, the remaining packages can be installed normally using yum.

Attachments

    Outcomes