000029145 - Error message "Public key for package xxxxxx not installed" when upgrading an appliance to RSA Security Analytics 10.4

Document created by RSA Customer Support Employee on Jun 15, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000029145
Applies ToRSA Product Set: Security Analytics
RSA Product/Service Type: Core Appliance
RSA Version/Condition: 10.3
Platform: CentOS
O/S Version: 6
IssueOccasionally, when a core appliance is upgraded from 10.3 to 10.4, an error message similar to the following is displayed:  Public Key for package xxxxxx is not installed
CauseThis issue occurs because the public keys for a component has not been installed.
ResolutionIn order to resolve the issue, follow the steps below.
  1. Connect to the appliance that is experiencing the issue via SSH.
  2. Issue the following command to import the public key:  rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6
  3. Perform the update again by issuing the following command:  yum update
If error still occurs, follow the steps below.
  1. Download the 3rd party public keys from the RSA SecurCare Online portal.
  2. Transfer the file to appliance in question.
  3. Unpack the rsa-sa-gpg-pubkeys-10.4.zip file.
  4. From the directory in which the unzipped package resides, issue the following command to install the keys:  rpm -ivh rsa-sa-gpg-pubkeys-10.4.0.1.1116-1.el6.noarch.rpm
  5. Perform the update again by issuing the following command:  yum update
If you are unsure of any of the steps above or experience any issues, contact RSA Support and quote this article number for further assistance.

Attachments

    Outcomes