000029330 - Issues when upgrading the rpm nss-softokn-freebl package through the RSA Security Analytics UI "Execution of /usr/bin/yum......Multilib version problems found"

Document created by RSA Customer Support Employee on Jun 15, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 3Show Document
  • View in full screen mode

Article Content

Article Number000029330
Applies ToRSA Product Set: Security Analytics
RSA Product/Service Type: Security Analytics Server
RSA Version/Condition: 10.4.0.0 and later
Platform: CentOS
O/S Version: EL6
IssueIn Administration -> Appliances in the SA UI, there are 2 Updates Available.  However, an error occurs when attempting to install the latest packages.
When hovering over the "Error" in the Status column of the 1st package, a similar message is displayed:
"Execution of '/usr/bin/yum -d 0 -e 0 -y install nss-softokn-freebl' returned 1: Error: Multilib version problems found."

User-added image
Hovering over the Error in the Status column of the 2nd package produces a very similar error.
User-added image
CauseThe issue occurs because both i686 and x86_64 versions of the same package are installed.
ResolutionIn order to resolve the issue, SSH to the SA Server and run the following command:
 
[root@AIO ~]# yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
RSASoftware                                              | 2.9 kB     00:00
RSASoftware/primary_db                                   | 1.0 MB     00:00
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package nss-softokn-freebl.i686 0:3.14.3-10.el6_5 will be updated
---> Package nss-softokn-freebl.x86_64 0:3.14.3-10.el6_5 will be updated
---> Package nss-softokn-freebl.i686 0:3.14.3-12.el6_5 will be an update
---> Package nss-softokn-freebl.x86_64 0:3.14.3-12.el6_5 will be an update
--> Finished Dependency Resolution
Dependencies Resolved
================================================================================
Package                Arch       Version                Repository       Size
================================================================================
Updating:
nss-softokn-freebl     i686       3.14.3-12.el6_5        RSASoftware     147 k
nss-softokn-freebl     x86_64     3.14.3-12.el6_5        RSASoftware     158 k
Transaction Summary
================================================================================
Upgrade       2 Package(s)
Total download size: 305 k
Is this ok [y/N]: y
Downloading Packages:
(1/2): nss-softokn-freebl-3.14.3-12.el6_5.i686.rpm       | 147 kB     00:00
(2/2): nss-softokn-freebl-3.14.3-12.el6_5.x86_64.rpm     | 158 kB     00:00
--------------------------------------------------------------------------------
Total                                            56 MB/s | 305 kB     00:00
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : nss-softokn-freebl-3.14.3-12.el6_5.x86_64                    1/4
  Updating   : nss-softokn-freebl-3.14.3-12.el6_5.i686                      2/4
  Cleanup    : nss-softokn-freebl-3.14.3-10.el6_5                           3/4
  Cleanup    : nss-softokn-freebl-3.14.3-10.el6_5                           4/4
  Verifying  : nss-softokn-freebl-3.14.3-12.el6_5.x86_64                    1/4
  Verifying  : nss-softokn-freebl-3.14.3-12.el6_5.i686                      2/4
  Verifying  : nss-softokn-freebl-3.14.3-10.el6_5.i686                      3/4
  Verifying  : nss-softokn-freebl-3.14.3-10.el6_5.x86_64                    4/4
Updated:
  nss-softokn-freebl.i686 0:3.14.3-12.el6_5
  nss-softokn-freebl.x86_64 0:3.14.3-12.el6_5
Complete!
NotesThis article assumes that the SA Repository has been correctly setup so that commands such as 'yum update' work from the command line.
This could probably also be resolved by performing the following:
rpm -e nss-softokn-freebl.i686 0:3.14.3-10.el6_5.i686

Other RPM's where this issue could occur are:

libgcc.i686
libgcc.x86_64
 
libstdc++.i686
libstdc++.x86_64
 
nss-softokn-freebl.i686
nss-softokn-freebl.x86_64
audit-libs.i686
audit-libs.x86_64
 
elfutils-libelf.i686
elfutils-libelf.x86_64
 
libsselinux.x86_64
libsselinux.i686
 
pam.i686.x86_64
pam.x86_64

Error Messages are always of the form:
Execution of '/usr/bin/yum -d 0 -e 0 -y install libgcc' returned 1: Error: Multilib version problems found. This often means that the root cause is something else and multilib version checking is just pointing out that there is a problem. Eg.: 1. You have an upgrade for libgcc which is missing some dependency that another package requires. Yum is trying to solve this by installing an older version of libgcc of the different architecture. If you exclude the bad architecture yum will tell you what the root cause is (which package requires what). You can try redoing the upgrade with --exclude libgcc.otherarch ... this should give you an error message showing the root cause of the problem. 2. You have multiple architectures of libgcc installed, but yum can only see an upgrade for one of those arcitectures. If you don't want/need both architectures anymore then you can remove the one with the missing update and everything will work. 3. You have duplicate versions of libgcc installed already. You can use "yum check" to get yum show these errors. ...you can also use --setopt=protected_multilib=false to remove this checking, however this is almost never the correct thing to do as something else is very likely to go wrong (often causing much more problems). Protected multilib versions: libgcc-4.4.7-11.el6.x86_64 != libgcc-4.4.7-4.el6.i686 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles –nodigest

Attachments

    Outcomes