000013629 - FIM 4.x - Error running cliCreateUserGroupsForWLS

Document created by RSA Customer Support Employee on Jun 16, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000013629
Applies ToRSA FIM 4.1
BEA Weblogic 9.2 or 10.1
IssueFIM 4.x - Running cliCreateUserGroupsForWLS.cmd to add FIM admin users

When running the script "cliCreateUserGroupsForWLS" as described in the Install and Configuration guide page 36 the following error occurs:

WLST detected that the RuntimeMBeanServer is not enabled. This might happen if the RuntimeMBeanServer is disabled via the JMXMBean. Please ensure that this MBeanServer is enabled. Online WLST cannot function without this MBeanServer.
Exception in thread "Main Thread" Traceback (innermost last):
  File "<string>", line 1, in ?
  File "<iostream>", line 22, in connect
WLSTException: 'Error occured while performing connect : "Cannot connect to WLST
."For input string: "7001," Use dumpStack() to view the full stacktrace'

Cause

The documentation on page 36 is incorrect. It says to run the command with the following syntax:

5. Go to the directory FIM-domain-directory/rsa-fim-config/bin and type one of
the following commands, depending on your operating sytem:
? Windows or Solaris:
cliCreateUserGroupsForWLS.cmd username password
serveraddress:port, usersfilepath
? Linux:
cliCreateUserGroupsForWLS.sh username password
serveraddress:port, usersfilepath

The comma following the port should not be there.

Resolution

Execute the script with out the comma in the parameter list. For example:

C:\bea\user_projects\domains\fimdomain\rsa-fim-config\bin>cliCreateUserGroupsFor
WLS.cmd weblogic weblogic localhost:7001 C:\bea\user_projects\domains\fimdomain\
fimusers.properties

Notes

A successful execution of the script will produce an output similar to the following:

Your environment has been set.
Trying to connect to server
Connecting to t3://localhost:7001 with userid weblogic ...
Successfully connected to Admin Server 'AdminServer' that belongs to domain 'fim
domain'.

Warning: An insecure protocol was used to connect to the
server. To ensure on-the-wire security, the SSL port or
Admin port should be used instead.

Connected...
Creating groups...
Group [FIMAdmin] created successfully ...
Group [FIMSecurityAdmin] created successfully ...
Group [FIMFederationAdmin] created successfully ...
Group [FIMSuperAdmin] created successfully ...
User [myfimadmin] created successfully ...
user [myfimadmin] added to group [FIMSuperAdmin] successfully ...

Done.

Legacy Article IDa46176

Attachments

    Outcomes