000022534 - Error: 'Invalid digital signature' while installing BlackBerry 8700

Document created by RSA Customer Support Employee on Jun 16, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000022534
Applies ToRSA SecurID Software Token for BlackBerry Handhelds 2.0
BlackBerry 8700, 8703E, 8800 and 8830
RIM OS 4.1.0.258
RIM OS 4.1.0.194
RIM Desktop 4.1.0.10
IssueError: "Invalid digital signature" while installing BlackBerry 8700
Error: "Uncaught exception java.lang.error" when RSA SecurID Software Token application is selected and wheel is pressed

Error: ?The following modules could not be loaded because their digital signatures were invalid? 

Resolution

This issue has been resolved in a hot fix for RSA SecurID Software Token for BlackBerry Handhelds 2.0. Contact RSA Security Customer Support to obtain this hot fix.

Note: This fix is a cumualtive hot fix and will work with all BlackBerry models. If you are installing Software token on models such as 8800 and 8830, it is highly recommended to download the most recent version of Desktop Manager with Service Pack 2 from Blackberry web site, dated 5/18/07.

This fix will resolve the following issues:

a. Token code does not change after 60 seconds, though the small bar changes indicating the change in time.

b. Software Token application freezes on some devices.

c. Software Token cannot be installed on some models with the above listed errors.

This version of application requires only two files. The hot fix zip file contains these two files namely, SecurID.alx and SecurID.cod. The original distribution used to have 3 files. SecurIDLib.cod, is from the original distribution, and is no longer needed. The file SecurID.cod has been created after merging the 2 original files (SecurID.cod and SecurIDLib.cod).

A. Delete the following files (from the provisioning BES server) everywhere they are on the server:

SecurID.alx or SecureID.alx or both

SecurID.cod or SecureID.cod or both

SecurIDLib.cod or SecureIDlib.cod or both

B. Install only the following two files from the hot fix ZIP file you received from the RSA Security Customer Support:

SecurID.alx

SecurID.cod

This fix will work with all models of BlackBerry.

There is one "hot fix" (2006-04-10),  and two service packs for BES version 4.1, and (2006-07-21 and 2006-09-12) , all of which  should be applied on BlackBerry Enterprise Server. Download the fixes from BlackBerry web site: <http://www.blackberry.com/knowledgecenter/livelink.exe>
Visit the BlackBerry web site at http://www.blackberry.com/support/documentation/server/index.shtml to download the service packs (then select Downloads > Service Packs). You will see a drop-down menu based on which version of BES you would like service packs for; select the appropriate BES and follow the instructions. The package you download includes a Readme file for steps to take. Please refer to knowledgebase articles KB04882 and KB04907 from www.blackberry.com/support for instructions on installing service packs and hot fixes.

Legacy Article IDa30852

Attachments

    Outcomes