000023118 - Ignore_http_auth parameter does not work in the 3.5 Agent for Weblogic

Document created by RSA Customer Support Employee on Jun 16, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000023118
Applies ToRSA ClearTrust Agent 3.5.2 for BEA WebLogic
BEA Weblogic 8.1

The following parameters are set in the webagent.conf file.

cleartrust.agent.ignore_http_auth=false 
cleartrust.agent.form_based_enabled=Yes

IssueUsing HTTP-Authorization headers to access a protected resource
When attempting to use HTTP-Authorization headers to access a protected resource,  instead of receiving the protected resource the customer receives the login form. Using the wget (1.10.2) tool to access a protected resource.
CauseThe code to support the parameter ignore_http_auth is not present in the Agent.
ResolutionThis issue has been resolved in a hot fix for RSA ClearTrust Agent 3.5.2. Contact RSA Security Customer Support to obtain hot fix 3.5.2.10, or request the latest fix level (which is cumulative, and contains fixes from previous fix levels).
NotesSee related agentconfig GUI hot fix 3.5.2.11
Legacy Article IDa32275

Attachments

    Outcomes