000012587 - FIM console will not load due to class loader error.

Document created by RSA Customer Support Employee on Jun 16, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000012587
Applies ToFederated Identity Management Module 4.1
IssueFIM console will not load due to class loader error.
The FIM console crashes after entering the Administrator credentials

The following error message is displayed in the standard output for the FIM managed server:

Sep 28, 2010 1:33:51 PM org.apache.struts.actions.DispatchAction dispatchMethod
SEVERE: Dispatch[/Dashboard] to method nvPreView returned an exception
java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:592)
        at org.apache.struts.actions.DispatchAction.dispatchMethod(DispatchAction.java:280)
        at com.rsa.ui.common.struts.action.RSABaseDispatchAction.execute(RSABaseDispatchAction.java:200)
        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:484)

CauseThis failure may occur any time the extended class loader is unable to use the JNDI service to load FIM classes.  The exact stack trace may be different depending on what class is being loaded at the time of failure.  In this instance FIM is unable to contact the JNDI service due to a problem with the SSL JNDI URL.
Resolution

The description in the fim.properties file for configuring the JNDI URL for SSL is incorrect.  The fim.properties file contains two parameters, one for non SSL and one for SSL:

jndi.url=t3://localhost:7001
jndi.ssl.url=t3s://localhost:7002

The parameter jndi.ssl.url is not used by FIM and is not read when parsing the FIM properties file.  Only the jndi.url parameter is used.

If you wish to use SSL for the JNDI URL specifiy a t3s URL for the jndi.url parameter as in this example:

jndi.url=t3s://localhost:7002

WorkaroundConfigured FIM in stand alone mode (not clustered) with the non SSL port disabled for the t3 JNDI URL.
Notes

 The documentation in the fim.properties file will be changed in a future version to reflect the correct configuration.

Legacy Article IDa52596

Attachments

    Outcomes