000021824 - Changes to email server settings not taking effect in RSA SecurID Web Express

Document created by RSA Customer Support Employee on Jun 16, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000021824
Applies ToRSA SecurID Web Express 1.2
RSA Authentication Deployment Manager 1.2
Modified config.properties to change point Web Express to a new email server
IssueChanges to email server settings not taking effect in RSA SecurID Web Express
RSA SecurID Web Express still trying to send email through original server
CauseRSA SecurID Web Express will cache the email server settings until the Security Block within config.properies is removed
ResolutionTo correct this issue, open up the <WebExpressInstallDir>/JRun/servers/default/rsaswe/WEB-INF/config/config.properties file. Near the top of that file where your encrypted ACE username and password are defined, you will notice a line that reads "SECURITY_BLOCK_DO_NOT_REMOVE" followed by random text. Delete this line.

Also, delete the encrypted ACE username and password and retype them in plain text. If your database requires a username and password, you must do the same for the ODBC setting near the bottom of config.properties.

Then, ensure you have the new email server setting in config.properties, then save the file. Restart Web Express and it will generate a new Security Block and re-encrypt all your information. Web Express should now start using the new email settings.
Legacy Article IDa25267

Attachments

    Outcomes