000025590 - Default Installation of ClearTrust 6.0 causes Admingui to return 'needed JSSE provider 'SunJSSE' cannot be found exiting...' errors on WebSphere 6.1 on Solaris

Document created by RSA Customer Support Employee on Jun 16, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000025590
Applies ToSun Solaris 10
IBM WebSphere 6.1
RSA Access Manager 6.0
RSA ClearTrust Entitlements Manager (Admin GUI)
RSA Access Manager Runtime API
RSA Access Manager Admin API
IssueDefault installation of ClearTrust 6.0 causes admingui to return 'needed JSSE provider "SunJSSE" cannot be found exiting...' errors on WebSphere 6.1
In System Error logs on WebSphere 6.1 message 'needed JSSE provider "SunJSSE" cannot be found exiting...'
ClearTrust admingui.war hotfix level is at 6.0.0.04 or later.
Java runtime JRE is 1.5.0
CauseOn Solaris, the java.vendor for the JRE 1.5 used incorrectly determines that the java.vendor is Sun Microsystems, when in fact it is using the JSSE from IBM inside of WebSphere 6.1.
ResolutionA parameter needs to be added to config.ini inside of the profile directory where the admingui resides typically "/opt/IBM/WebSphere/AppServer/profiles/AppSrv01/configuration".   You need to add ct.force-ibmjvm=true to enable  a new system property "ct.force-ibmjvm".
NotesA good way to display the environment variable to further help debug this problem is to write a JSP page to cycle through and print out all the system properties.
To correct this you need to startup the WebSphere server with a JVM environment variable ct.force-ibmjvm=true that tells RSA Access Manager to use the IBM security libraries specifically.   To do this add a WebSphere System Property with the following value:
 
ct.force-ibmjvm=true
 
This can be done from "Application Servers/Server1/Process Definition/Java Virtual Machine/Custom Properties" menu in the WebSphere console.
Also see similar solution for RSA Access Manger Agent 4.7 for IBM WebSphere a47100 .
On Websphere Messgae Broker Toolkit , when this same error message is displayed, adding ct.force-ibmjvm=true to the JVM environment variable can resolve the error.
Legacy Article IDa38372

Attachments

    Outcomes