000014137 - Error message 'Protocol versions do not match  4!=3' or Protocol versions do not match 3!=4' in RSA NetWitness Administrator

Document created by RSA Customer Support Employee on Jun 16, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000014137
Applies ToRSA NetWitness NextGen
RSA NetWitness Administrator
RSA NetWitness Investigator
IssueError message "Protocol versions do not match, 4!=3" or Protocol versions do not match 3!=4" in RSA NetWitness Administrator.

You launch a NetWitness Client Application like NetWitness Administrator or NetWitness Investigator and when you attempt to connect to a NextGen Appliance (Concentrator, Broker or Decoder) you receive a message similar to the following:

Protocol versions do not match, 4!=3  or  Protocol versions do not match, 3!=4

Cause

These messages indicate a mismatch between your client software and your appliance software.

  • Protocol versions do not match, 4!=3 -- Trying to access a 9.5.x.x appliance with a 9.0.x.x Client Program (Administrator or Investigator)
  • Protocol versions do not match, 3!=4 -- Trying to access a 9.0.x.x appliance with a 9.5.x.x Client Program (Administrator or Investigator)
Resolution

RSA NetWitness NextGen does not support mixed version environments and different versions of NetWitness are not interoperable.  Version 9.5 is not backward compatible with 9.0. or any other previous version. 

 

You will either need to downgrade your client software or upgrade your appliance software as appropriate.  The RSA NetWitness solution library contains instructions for obtaining and upgrading your RSA NetWitness products to the latest versions.

Legacy Article IDa58756

Attachments

    Outcomes