000026003 - Error: 'Fatal: libthread.so.1: version 'SUNW_1.4' not found' while installing RSA ACE/Agent 5.1 on Sun Solaris 2.6 or 2.7

Document created by RSA Customer Support Employee on Jun 16, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000026003
Applies ToRSA ACE/Agent 5.1 for UNIX
RSA ACE/Server 5.1 (no longer supported as of 7-14-2006)
Sun Solaris 2.6
Sun Solaris 2.7
IssueError: "Fatal: libthread.so.1: version 'SUNW_1.4' not found" while installing RSA ACE/Agent 5.1 on Sun Solaris 2.6 or 2.7
After running sdsetup -agent from the appropriate directory (with the license files in it), the following error appears:

    ld.so.1: /cdrom/as51173/aceagent/sol/sdinstall/sdcfgval: fatal: libthread.so.1: version `SUNW_1.4' not found
    (required by file /cdrom/as51173/aceagent/sol/sdinstall/sdcfgval)

   You must be root in order to run 'sdsetup'.  Please 'su' to root or
    log out and log in as root.

    Aborting sdsetup...

    Sdsetup aborted.
ResolutionRSA ACE/Server and the ACE/Agents on the server CD are build with Sun Solaris 2.8. The documentation file unix_install.pdf incorrectly states that Solaris 2.6 and 2.7 are supported environments. This is a documentation error, and it will be necessary to use the RSA ACE/Server 5.0.1 CD to install on Solaris 2.6.

The build environment for RSA ACE/Server 5.1 is Solaris 2.8; therefore, Solaris 2.8 or greater is required to run RSA ACE/Agent 5.1.
Legacy Article IDa17568

Attachments

    Outcomes