000014553 - How to enable HTTP client logon in WebLogic

Document created by RSA Customer Support Employee on Jun 16, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000014553
Applies ToFederated Identity Management Module 4.0
IssueHow to enable HTTP client logon in WebLogic
The following error shows up in the WebLogic Admin server logs when attempting to deploy the FIMall.ear file.

<HTTPClntLogin: Login rejected with code: 'Failed', reason: java.net.ProtocolException: HTTP tunneling is disabled.
CauseWhen the FIM application is deployed the admin server acts as a JMS client and attempts to make a HTTPClntLogin (a client connection to server via a http tunnel). It does this so that it can communicate the changes to the cluster nodes. In weblogic 9.2 and higher http tunneling is disabled by default. This applicatin is able to be deployed,  but the admin server was unable to propogate necessary change information to cluster nodes.
ResolutionEnable HTTP tunneling for admin servers, and for for all manged servers. In the left hand window in the WebLogic Admininstative Console click on Environment and Servers.  Select each of the servers in the right hand window and then click on the Protocols tab.  Under the General section Enable Tunnelling by checking the checkbox.
Legacy Article IDa46778

Attachments

    Outcomes