000021531 - Getting 'null' in web browser when trying to access RSA SecurID Web Express pages

Document created by RSA Customer Support Employee on Jun 16, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000021531
Applies ToMySQL 4.1
RSA SecurID Web Express 1.2
Sun Solaris 2.9
IssueGetting 'null' in web browser when trying to access RSA SecurID Web Express pages
The 'default-out.log' on the JRun log shows the following:

15:13:40  web-0 Syntax error or access violation message from server: "Access denied for user ''@'<hosts>' to database 'RSAWE_Transaction_Database'"
15:13:40  web-0 WburDbService.WburService: Failed to connect to db: Syntax error or access violation message from server: "Access denied for user ''@'<hosts>' to database 'RSAWE_Transaction_Database'"
Cause
User assigned for MySQL database is not configured in 'config.properties' file in RSA SecurID Web Express
Resolution
To correct this issue, in the 'config.properties' file, make sure there is an entry for "DB_USER_ID" and "ARCHIVE_DB_USER_ID" as shown below:
 
# Active Requests Database
#DRIVER_NAME=sun.jdbc.odbc.JdbcOdbcDriver
DRIVER_NAME=com.mysql.jdbc.Driver
DB_USER_ID=usersql01
DB_PASSWORD=password
#DB_URL=jdbc:odbc:RSAWE_Transaction_Database
DB_URL=jdbc:MySQL://localhost:3306/RSAWE_Transaction_Database
INIT_CONN_SIZE=1
MAX_CONN_SIZE=200
# Archive Requests Database
ARCHIVE_DRIVER_NAME=com.mysql.jdbc.Driver
ARCHIVE_DB_USER_ID=usersql01
ARCHIVE_DB_PASSWORD=password
#ARCHIVE_DB_URL=jdbc:odbc:RSAWE_Archive_Database
ARCHIVE_DB_URL= jdbc:MySQL://localhost:3306/RSAWE_Archive_Database
ARCHIVE_INIT_CONN_SIZE=1
ARCHIVE_MAX_CONN_SIZE=200

Also, make sure the user 'usersql01' has been granted privileges. If privileges have not been granted, perform the following from MySQL prompt:
GRANT ALL PRIVILEGES ON *.* TO usersql01@localhost IDENTIFIED BY 'password' WITH GRANT OPTION; 
Legacy Article IDa23442

Attachments

    Outcomes