000022225 - How to use Microsoft SQL 2000 SP3 with RSA Reporting and Compliance Manager 1.0

Document created by RSA Customer Support Employee on Jun 16, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000022225
Applies ToRSA Reporting and Compliance Manager 1.0
Microsoft SQL Server 2000 SP3
RSA ClearTrust 5.5
All Microsoft Windows Platforms
Apache Tomcat
IssueHow to use Microsoft SQL 2000 SP3 with RSA Reporting and Compliance Manager 1.0
Error: "org.apache.slide.common.Domain - ERROR - Domain initialization error" in RSA Reporting and Compliance Manager
TCP/IP connection failed to host: failed to host:java.net.ConnectException: Connection refused: connect url:jdbc:SQLConnect://localhost:1433/database=RCM
initialization failed : SQL ErrorFailed Logon:com.jnetdirect.jsql.v: Login failed for user 'ct_admin'. Reason: Not associated with a trusted SQL Server connection. url:jdbc:JSQLConnect://localhost:1433/database=RCM
ResolutionTo correct this issue, follow these steps:

1. Make sure Microsoft SQL 2000 has SP3 or later applied

2. In the SQL Server Enterprise Manager, do the following:

- Expand Microsoft SQL Servers

- Expand SQL Server Group

3. Under SQL Server Group, you will see your SQL Server ( RCM10\RCM (Windows NT) )

4. Right click the server name and go to Properties - this will bring up the "SQL Server Properties (Configure)" screen

5. Select the Security tab

6. Under Authentication, select the "SQL Server and Windows" radio button

7. Next, click the General tab at the top

8. At the bottom, click the "Network Configuration" button

9. On the next screen, click the General tab and make sure TCP/IP is under the "enabled protocols" window (to the right)

10. Click TCP/IP in this box and click the "Properties" button

11. Make sure the default port reads "1433"

12. Click OK and all the other "OK" or "Apply" buttons to exit out of the Enterprise Manager

13. Restart all SQL Server services

14. At a DOS/command window, run  netstat ?an | find "1433" - this will ensure SQL Server is now listening on the default port

You should now be able to launch the "Start Server" icon installed with RSA Reporting and Compliance Manager 1.0.
Legacy Article IDa27570

Attachments

    Outcomes