000022158 - Java Cryptography Extension (JCE) 1.2.1 Package (Signing Certificate) Expires on July 27  2005

Document created by RSA Customer Support Employee on Jun 16, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000022158
Applies ToJava Cryptography Extension (JCE) 1.2.1
RSA BSAFE Crypto-J
IssueJava Cryptography Extension (JCE) 1.2.1 Package (Signing Certificate) Expires on July 27, 2005
Exception in thread "main" java.lang.ExceptionInInitializerError:

    java.lang.SecurityException: Cannot set up certs for trusted CAs
         at javax.crypto.b.<clinit>([DashoPro-V1.2-120198])
         at javax.crypto.KeyGenerator.getInstance([DashoPro-V1.2-120198])
CauseSun's Java Cryptography Extension (JCE) 1.2.1 Package (Signing Certificate) expires on July 27, 2005. According to Sun, JCE 1.2.1 is at "End of Service Life" (EOSL), and is no longer supported. JCE 1.2.1 was EOSL'ed in 2002 when JCE 1.2.2 was released. Please see the Sun bulletin at http://sunsolve.sun.com/search/document.do?assetkey=1-26-101796-1&searchclause. This will not have an effect on users of RSA BSAFE Crypto-J who are not using the Java Cryptography Extension (JCE) interface.
ResolutionIf using J2SE 1.2.x or 1.3.x, upgrade to Java Cryptography Extension (JCE) 1.2.2. Alternatively, upgrade to J2SE 1.4+, which includes a newer version of the JCE.
Legacy Article IDa27151

Attachments

    Outcomes