000033392 - Packaging fails with error "Could not connect to Advanced Workflow Service" when Advanced Workflow is accessible by users in RSA Archer 6.1

Document created by RSA Customer Support Employee on Jul 4, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 3Show Document
  • View in full screen mode

Article Content

Article Number000033392
Applies ToRSA Product Set: Archer
RSA Product/Service Type: Archer
RSA Version/Condition: 6.1
Platform: Windows
IssueUsers are able to create and configure Advanced Workflows in applications, but when packaging those applications, the package generation fails with the following error:
 
User-added image
    
  
Could not connect to the Advanced Workflow Service to export package "abc123". Please review the job log for details.

  
  
   The following log entry can also be found in Jobframework.job in the Logging\(InstanceName) folder.
  
<E2ETraceEvent xmlns="http://schemas.microsoft.com/2004/06/E2ETraceEvent">
  <System xmlns="http://schemas.microsoft.com/2004/06/windows/eventlog/system">
    <EventID>1</EventID>
    <Type>3</Type>
    <SubType Name="Critical">0</SubType>
    <Level>1</Level>
    <TimeCreated SystemTime="2016-06-09T16:56:22.0838638Z" />
    <Source Name="Archer.Kernel.WorkflowService" />
    <Correlation ActivityID="{6bb1cd70-aa69-4062-ae02-18f3d0226b53}" />
    <Execution ProcessName="ArcherTech.JobFramework.Job" ProcessID="8792" ThreadID="11" />
    <AssemblyVersion>6.1.0.1152</AssemblyVersion>
    <Channel />
    <Computer>*REMOVED*</Computer>
  </System>
  <ApplicationData>
    <TraceData>
      <DataItem>
        <TraceRecord Severity="Critical" xmlns="http://schemas.microsoft.com/2004/10/E2ETraceEvent/TraceRecord">
          <TraceIdentifier>Archer.Kernel.WorkflowService</TraceIdentifier>
          <Description>Advanced workflow HTTP request error:</Description>
          <AppDomain>ArcherTech.JobFramework.Job.exe</AppDomain>
          <Exception>
            <ExceptionType>System.Net.Http.HttpRequestException, System.Net.Http, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a</ExceptionType>
            <Message>An error occurred while sending the request.</Message>
            <Source>mscorlib</Source>
            <StackTrace> at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at ArcherTech.Kernel.Services.Workflow.WorkpointService.&lt;WrapHttpRequest&gt;d__89.MoveNext()</StackTrace>
            <InnerException>
              <ExceptionType>System.Net.WebException, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089</ExceptionType>
              <Message>Unable to connect to the remote server</Message>
              <Source>System</Source>
              <StackTrace> at System.Net.HttpWebRequest.EndGetRequestStream(IAsyncResult asyncResult, TransportContext&amp; context)
at System.Net.Http.HttpClientHandler.GetRequestStreamCallback(IAsyncResult ar)</StackTrace>
              <InnerException>
                <ExceptionType>System.Net.Sockets.SocketException, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089</ExceptionType>
                <Message>No connection could be made because the target machine actively refused it *IP ADDRESS*:8000</Message>
                <Source>System</Source>
                <StackTrace> at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket&amp; socket, IPAddress&amp; address, ConnectSocketState state, IAsyncResult asyncResult, Exception&amp; exception)</StackTrace>
              </InnerException>
            </InnerException>
          </Exception>
        </TraceRecord>
      </DataItem>
    </TraceData>
  </ApplicationData>
</E2ETraceEvent>

  
  
  
  
    
CauseThe RSA Archer Job Engine Service running on the services server cannot reach the Workflow Service running on the Web Server.
The Job Engine service expects the advanced workflow service to be at  *IP ADDRESS*:8000.
 
Resolution

If *IP ADDRESS* is a web server then log into *IP ADDRESS*, start the Advanced Workflow Service and make sure port 8000 is not firewalled on the web server.
If *IP ADDRESS* in the log is a services server that does not run the Advanced Workflow Service, then the following configuration change needs to be made in the Archer Control Panel's Installation Settings:
User-added image
In the Workflow Host field, change "localhost" to the load balancer URL or a web server IP address that is running IIS and the Workflow Service.

Attachments

    Outcomes