000033514 - Packaging issues in RSA Archer 6.X

Document created by RSA Customer Support Employee on Jul 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000033514
Applies ToRSA Product Set: Archer
RSA Product/Service Type: Archer
RSA Version/Condition: 6.X
Platform: Windows
 
IssueWhen trying to generate a package in 6.X that uses Advanced Workflow, it fails. 
CauseThe following error is found in the Job Framework logs:
 
<E2ETraceEvent xmlns="http://schemas.microsoft.com/2004/06/E2ETraceEven">
    <System xmlns="http://schemas.microsoft.com/2004/06/windows/eventlog/system">
        <EventID>2</EventID>
        <Type>3</Type>
        <SubType Name="Error">0</SubType>
        <Level>2</Level>
        <TimeCreated SystemTime="2016-07-08T16:50:26.4220165Z" />
        <Source Name="Archer.Kernel.WorkflowService" />
        <Correlation ActivityID="{eb9acee7-e741-45d9-bf6f-959a31af683e}" />
        <Execution ProcessName="ArcherTech.JobFramework.Job" ProcessID="12148" ThreadID="14" />
        <AssemblyVersion>6.0.0.1470</AssemblyVersion>
        <Channel />
        <Computer>XXXXXXXXXXXX</Computer>
    </System>
    <ApplicationData>
        <TraceData>
            <DataItem>
                <TraceRecord Severity="Error" xmlns="http://schemas.microsoft.com/2004/10/E2ETraceEvent/TraceRecord">
                    <TraceIdentifier>Archer.Kernel.WorkflowService</TraceIdentifier>
                    <Description>Advanced workflow API error: The server login was denied for the following reason: Authentication Failed for user XXX</Description>
                    <AppDomain>ArcherTech.JobFramework.Job.exe</AppDomain>
                    <ContextData>
                        <WorkpointMessage>Advanced workflow API error: The server login was denied for the following reason: Authentication Failed for user XXX</WorkpointMessage>
                        <WorkpointException>java.lang.RuntimeException</WorkpointException>
                        <WorkpointHttpRequest>Method: POST, RequestUri: 'http://XXXXXXXXX/wp-architect-java/auth/login', Version: 1.1, Content: System.Net.Http.ObjectContent`1[[ArcherTech.Kernel.Services.Workflow.Workpoint.AuthRequest, ArcherTech.Kernel, Version=6.0.0.1470, Culture=neutral, PublicKeyToken=null]], Headers:
{
  wp-product-name: archer
  Content-Type: application/json; charset=utf-8
  Content-Length: 116
}</WorkpointHttpRequest>
                        <WorkpointServiceMethod>ArcherTech.Kernel.Services.Workflow.WorkpointService.LoginWithCredentialsSource: line 564</WorkpointServiceMethod>
                    </ContextData>
                </TraceRecord>
            </DataItem>
        </TraceData>
    </ApplicationData>
</E2ETraceEvent>
Resolution1.  Open Microsoft IIS
2.  Open the RSA Archer Site
3.  Select the API application
4.  Select "Authentication"
5.  Enable "Anonymous" authentication
5.  Disable ANY other authentication type for the API application
6.  Perform an IIS reset

Attachments

    Outcomes