000033617 - Browsing to Microsoft Silverlight pages using HTTPS fail with "An unexpected error has occurred in the system" in RSA Archer

Document created by RSA Customer Support Employee on Jul 26, 2016Last modified by RSA Customer Support on Apr 3, 2019
Version 3Show Document
  • View in full screen mode

Article Content

Article Number000033617
Applies ToRSA Product Set: Archer
RSA Product/Service Type: RSA Archer (On-Premise)
RSA Version/Condition: 5.5 & 6.x
O/S Version: Windows
Browser: IE (any version)
 
IssueWhenever  trying to access Microsoft Silverlight enabled pages with HTTPS, The below error occurs:
 

“An unexpected error has occurred in the system. The error Log Reference ID is: MMDDYY-HHMMSS-XXXX. Please try your request again.   If problems persist, please contact your system administrator.”


Sample error from Archerw3wp log:

<ApplicationData>
  <TraceData>
    <DataItem>
      <TraceRecord Severity="Error" xmlns="http://schemas.microsoft.com/2004/10/E2ETraceEvent/TraceRecord">
        <TraceIdentifier>Archer.Web</TraceIdentifier>
        <LogReferenceId>052815-140634-1571</LogReferenceId>
        <Description>[HttpWebRequest_WebException_RemoteServer]Arguments: NotFoundDebugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See http://go.microsoft.com/fwlink/?linkid=106663&Version=5.1.40416.0&File=System.Windows.dll&Key=HttpWebRequest_WebException_RemoteServer</Description>
       
<AppDomain>/LM/W3SVC/1/ROOT/RSAarcher-1-130772951733443985</AppDomain>
        <ContextData>
          <BaseUrl>https://XXXXXXXXXXXX/RSAarcher/Integration/DataImportManager.aspx</BaseUrl>
          <PageID>ManageDataImport</PageID>
          <Module>ModuleId: 149, ModuleName: Business Unit, ModuleStatus: ActiveInProduction, ModuleType: Application</Module>
          <IsEndUserView>true</IsEndUserView>
        </ContextData>
        <Exception>
          <ExceptionType>ArcherTech.Web.UI.ArcherException, ArcherTech.Web, Version=6.0.0.1271, Culture=neutral, PublicKeyToken=null</ExceptionType>
          <Message>[HttpWebRequest_WebException_RemoteServer]Arguments: NotFoundDebugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See http://go.microsoft.com/fwlink/?linkid=106663&Version=5.1.40416.0&File=System.Windows.dll&Key=HttpWebRequest_WebException_RemoteServer</Message>
         
<Source>
          </Source>
          <StackTrace> at System.ServiceModel.AsyncResult.End[TAsyncResult](IAsyncResult result) at System.ServiceModel.Channels.ServiceChannel.EndCall(String action, Object[] outs, IAsyncResult result) at System.ServiceModel.ClientBase`1.ChannelBase`1.EndInvoke(String methodName, Object[] args, IAsyncResult result) at ArcherTech.SL.ManageAppearance.Proxy.AppearanceThemeService.AppearanceThemeServiceClient.AppearanceThemeServiceClientChannel.EndGetActive(IAsyncResult result) at ArcherTech.SL.ManageAppearance.Proxy.AppearanceThemeService.AppearanceThemeServiceClient.ArcherTech.SL.ManageAppearance.Proxy.AppearanceThemeService.IAppearanceThemeService.EndGetActive(IAsyncResult result) at ArcherTech.SL.ManageAppearance.Proxy.AppearanceThemeService.AppearanceThemeServiceClient.OnEndGetActive(IAsyncResult result) at System.ServiceModel.ClientBase`1.OnAsyncCallCompleted(IAsyncResult result)</StackTrace>
        </Exception>
      </TraceRecord>
    </DataItem>
  </TraceData>
</ApplicationData>


 
CauseThe issue is caused when the web.config file is set up for HTTP/NO SSL and user tried to browse Archer with HTTPS/SSL. 
ResolutionYou can solve the problem by:
  1. Make the following 4 changes in C:\inetpub\wwwroot\RSAarcher\web.config file:
    1. Search for httpGetEnabled attribute and change from <serviceMetadata httpGetEnabled="false" /> to <serviceMetadata httpsGetEnabled="true" />
    2. Search for <security mode="Transport" /> and uncomment it
    3. Search for <httpTransport maxReceivedMessageSize and change from <httpTransport maxReceivedMessageSize to <httpsTransport maxReceivedMessageSize
    4. Search for <httpTransport transferMode="StreamedRequest" and change from <httpTransport transferMode="StreamedRequest" to <httpsTransport transferMode="StreamedRequest"

    Or..


  2. Download the web config editor from here and follow the instruction to update your current web.config file using the editor. Toggle on SSL settings if you want to use https.

    Perform an IIS reset after applying the changes. 

    All the Silverlight pages should be accessible with HTTPS without any issues.


NotesNOTE: Silverlight pages are working fine with HTTP.

Attachments

    Outcomes