Hosts GS: 56553

Document created by RSA Information Design and Development on Jul 27, 2016
Version 1Show Document
  • View in full screen mode
 

This section contains the 10.5.1 pre-update check and update error messages with a description of each message and instructions on how to respond to these messages.

Pre-Update Check Errors

Security Analytics examines your current configuration for settings that are incompatible with the update. If it encounters incompatible settings, it displays in the Updates column of the Hosts view. To resolve these conflicts:

  1. Click on to display the error message with a description of the incompatible and the compatible configuration values.
  2. Reconfigure the values to make them compatible.
  3. Retry the update.

Troubleshooting

The following tables describes possible errors and potential solutions.

                 
Error Message

(blank)

CauseThe host.manifest file is missing.
Required Action

Make sure that the host.manifest file is on the Security Analytics Server host in:

/var/netwitness/srv/www/rsa/updates/RemoteRPMs/
sa/10.5.1/manifest/host.manifest
.

If you cannot find host.manifest, contact Customer Care.

 

                 
MessageCould not access version information from host hostname. Wait a few seconds and select "Check Updates" again.
CauseSecurity Analytics server cannot determine the version of the host during check update because it is still starting up.
Required ActionWait a few minutes for the Security Analytics server to start then select "Check Updates" again. Make sure that host services are up and running.

 

                 
Error Message

File system check failed.

Insufficient space in /var/lib/rabbitmq partition.

Used space for this partition should be less than 80%.

Current Status: percentage-used%

Possible CauseMessages are backing up in the /var/lib/rabbitmq partition.
Required ActionInvestigate why the messages are backing up and resolve this issue. If you cannot resolve this issue, contact Customer Care.

 

                 
Error MessageKernel version on the host is newer than the version 2.6.32-504.1.3 supported by Security Analytics.
CauseUpdate to Security Analytics 10.5.1 is blocked because the kernel version is newer than version 2.6.32-504.1.3 supported by Security Analytics.
Required ActionThis message blocks you from updating to 10.5.1 so you must contact Customer Care to resolve the issue.

 

                 
Error Message

File system check failed.

/etc/grub.conf path requires symlink and is not symlink.

Current status: file

Cause10.5.1 requires that /etc/grub.conf is configured as a symbolic link (symlink) and your host has it configured as file.
Required ActionWait at least 30 minutes for puppet to complete and try to update again.

 

                 
Error Message

Update does not support current version as an update path.

You cannot update to 10.5.1 from current-version-number.

CauseValid 10.5.1 update paths are 10.4.1.x and 10.5.0.x and the host is not updated to either of these paths.
Required ActionUpdate the host to 10.4.1.x or later before you update to 10.5.1 and try to update the host again.

 

                 
Error MessageMissing required public (GPG) keys.

Host is missing the required public keys.

CauseYou must update the public keys on the application host before you can update to 10.5.1.
Required Action

Update the public keys on the application host.

  1. SSH to the application host.
  2. Run the following command to update the public keys.

    yum install rsa-sa-gpg-pubkeys –y --nogpgcheck

Update Errors

If Security Analytics encounters an error during the update process, it displays in the Updates column of the Hosts view. To resolve this error:

  1. Click on to display the packages and the details of the error.
  2. Correct the error if possible. If you cannot correct the error, contact Customer Care.
  3. Retry the update.

The following dialogs are the Update Errors Security Analytics will issue if it encounters while applying the 10.5.1 update packages to a host.

                 
Error Message

package-or-message-title.

Details follow the error message

CauseSecurity Analytics encountered a problem when applying the update.
Required ActionResolve the error in the message and try to update the host again. If you cannot correct the error, contact Customer Care.
You are here: (For 10.5.1 and Later Updates) Troubleshooting Host Updates > Troubleshooting 10.5.1 Pre-Update and Update Errors

Attachments

    Outcomes