000033704 - How to deactivate all Notifications in RSA Archer 5.x

Document created by RSA Customer Support Employee on Aug 8, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000033704
Applies ToRSA Product Set: Archer
RSA Version/Condition: 5.x
 
IssueHow to inactivate all Notifications in RSA Archer?
After moving the Instance database from one environment to another, need to inactivate all Notifications in environment. This should include all notifications, subscription and event based.
Workaround

Check out the following RSA Link / Community post: https://community.rsa.com/message/868910
To prevent notifications from being sent, use one or a combination of the following options:


  1. From the Archer Control Panel (ACP), change the SMTP Server to some bogus name/IP like 127.0.0.1 and set the retry settings to 0.
  2. Open each module and uncheck the Notifications checkbox on the General tab. This would allow you to test notifications on a per app basis.
  3. Disable notifications for all modules by running the following SQL command against the Instance database.  This is intended for non-prod environments and testing purposes only. Do not run in a Production environment. Be sure to perform SQL Backups before running in case a restore is needed. Use at your own risk!
    UPDATE tblModule SET notification_flag = 0 WHERE notification_flag = 1

  4. Update all users' email addresses to something bogus or blank.
  5. Delete users.

Attachments

    Outcomes