000033751 - Users unable to add datasource in RSA Security Analytics 10.5.2.0

Document created by RSA Customer Support Employee on Aug 12, 2016Last modified by RSA Customer Support Employee on Apr 22, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000033751
Applies ToRSA Product Set: Security Analytics
RSA Product/Service Type: SA Security Analytics Server
RSA Version/Condition: 10.5.2.0
Platform: CentOS
O/S Version: 6
 
IssueUsers are unable to add a data source when attempting to schedule a report and test a rule.
User-added image

Permissions for the affected role are set to Define, Delete and View Schedule.

User-added image

 
CausePermissions on the Data Sources need to be set correctly in order for users to select the Data Sources in the drop down fields.  
ResolutionTo modify the Data Source permissions, login as Administrator and navigate to the Security Analytics menu
 
  1. Dashboard > Administration >Services.
  2. In the Services panel, select a Reporting Engine service.
  3. Click Actns.png > View > Config.
    The Services Config Vview of Reporting Engine is displayed.
  4. Select the Sources tab.
  1. The Service Config View is displayed with the Reporting Engine Sources tab open.
    105_pre_sources_ tab.png
  2. Select the data source for which you want to configure permissions by selecting the checkbox.
  3. Click data_src_per.png.
    The Data Source Permissions dialog is displayed.
    105_Data-source-permissions.png
  4. Modify the access permission for different users based on the type of service account of the data source. The permission can be either Read Only or No Access.
  5. Click Save.
    The required permissions are configured for the data source. 

Attachments

    Outcomes