000032618 - Pre-upgrade script generates warnings and errors in RSA Security Analytics 10.4 or higher

Document created by RSA Customer Support Employee on Aug 17, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000032618
Applies ToRSA Product Set: RSA Security Analytics
RSA Product/Service Type: Appliance
RSA Version/Condition: Security Analytics 10.4 or higher.
 
IssueWhen running Pre-Upgrade for Security Analytics version >= 10.4 on an old Security Analytics appliance running EL5, Pre-Upgrade script throws kernel and bootloader issues as below:
/boot/grub/menu.lst is not a symlink. You will experience problems upgrading kernels.

/etc/sysconfig/kernel does not exist. You will experience problems upgrading kernels.

 
ResolutionFor /boot/grub/menu.lst , this can simply be fixed by running the below command as root:
ln -s /etc/grub.conf /boot/grub/menu.lst

For /etc/sysconfig/kernel , this warning can be ignored.
/etc/sysconfig/kernel is config file for mkinitrd.. mkinitrd was replaced by dracut which throws config files to many directories according to the nature of the kernel module, this can be found in the man page "man dracut".

Attachments

    Outcomes