000033859 - RSA Security Analytics: Log collector upgrade fails due to existing nwlogcollectortools package

Document created by RSA Customer Support Employee on Sep 2, 2016Last modified by RSA Customer Support on May 3, 2019
Version 4Show Document
  • View in full screen mode

Article Content

Article Number000033859
Applies ToRSA Product Set: NetWitness Logs & Network
RSA Product/Service Type: SA Log Decoder, SA Virtual Log Collector
RSA Version/Condition: 10.6.0.1, 10.6.0.2, 10.6.1.0
Platform: CentOS
O/S Version: EL6
IssueWhen upgrading Log Collector to higher than 10.6.0.0 version, the upgrade fails with below errors.

/var/lib/netwitness/uax/logs/sa.log:

2016-08-23 19:02:25,614 [Appliances Apply Updates Daemon 476396474]
ERROR com.rsa.smc.sa.admin.management.ApplianceUpdateEngine - Failed to update package
nwlogcollectortools.x86_64. Error is :"Execution of '/usr/bin/yum -d 0 -e 0 -y update nwlogcollectortools'
returned 1: Transaction Check Error:\n  file /etc/netwitness/ng/logcollector/static/logs/index.html from
install of nwlogcollectortools-10.6.1.0-14035.5.5aa3af4.el6.x86_64 conflicts with file from package
nwlogcollector-10.6.0.0.14466-5.el6.x86_64\n  file /etc/netwitness/ng/logcollector/static/logs/js/jquery-1.4.2.min.js
from install of nwlogcollectortools-10.6.1.0-14035.5.5aa3af4.el6.x86_64 conflicts with file from package
nwlogcollector-10.6.0.0.14466-5.el6.x86_64\n  file /etc/netwitness/ng/logcollector/static/logs/js/knockout-2.3.0.js
from install of nwlogcollectortools-10.6.1.0-14035.5.5aa3af4.el6.x86_64 conflicts with file from package
nwlogcollector-10.6.0.0.14466-5.el6.x86_64\n  file /etc/netwitness/ng/logcollector/static/logs/logs.js
from install of nwlogcollectortools-10.6.1.0-14035.5.5aa3af4.el6.x86_64 conflicts with file from package
nwlogcollector-10.6.0.0.14466-5.el6.x86_64\n  file /etc/netwitness/ng/logcollector/static/logs/style.css
from install of nwlogcollectortools-10.6.1.0-14035.5.5aa3af4.el6.x86_64 conflicts with file from package
nwlogcollector-10.6.0.0.14466-5.el6.x86_64\n\nError Summary\n-------------",
"sender":"0918ff32-6506-4e16-9f54-ba696ca1a13d","agent":"package"}]

In GUI error pops-up as below.

User-added image
 
CauseThis is due to existing nwlogcollectortools-10.6.0.0.14466-5.el6.x86_64 conflict package.
 
ResolutionPlease follow the below steps in sequence to resolve upgrade issue.
  1. Login to putty session of logcollector appliance.
  2. Run rpm -qa command to confirm the nwlogcollectortools package version.

    [root@XXX ~]# rpm -qa|grep -i nw
    nwconsole-10.6.1.0-7012.5.00709cb.el6.x86_64
    nwlogcollectortools-10.6.0.0.14466-5.el6.x86_64
    nwlogdecoder-10.6.1.0-7012.5.00709cb.el6.x86_64
    nwappliance-10.6.1.0-7012.5.00709cb.el6.x86_64
    nwlogcollector-10.6.1.0-14035.5.5aa3af4.el6.x86_64
    nwsupport-script-1.1-41.noarch
    nwlogcollectorperl-10.6.0.0-1.noarch
    nwlogcollectorcontent-20160120120154-1.noarch
    nwdecodercontent-10.6.1.0-7012.5.00709cb.el6.x86_64
    nwsdk-10.6.1.0-7012.5.00709cb.el6.x86_64
    nwlogdecoder-envision-base-content-20150331142850-1.x86_64
    nwlogdecoder-analytics-content-20150331224503-1.x86_64

  3. Run yum remove nwlogcollectortools-10.6.0.0.14466-5.el6.x86_64 to uninstall package.
  4. Try to upgrade collector now which should complete successfully.

Attachments

    Outcomes