000034027 - Upgrade Error in RSA Netwitness Endpoint(ECAT) 4.2: Error while executing SQL script ECAT_DELTA_4120_LATEST.SQL at line 133

Document created by RSA Customer Support Employee on Sep 16, 2016Last modified by RSA Customer Support Employee on Apr 22, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000034027
Applies ToRSA Product Set: Netwitness Endpoints
RSA Product/Service Type: ECAT Installer
RSA Version/Condition: 4.1.x, 4.2.0.0
Platform: Windows
Platform (Other): SQL 2012 Standard/Enterprise, SQL 2008 Standard/Enterprise
IssueThe below error message is seen in the install log on both single and multi-server deployments:
 

Error while executing SQL script ECAT_DELTA_4120_LATEST.SQL at line 133
SQLServerAgent is not currently running so it cannot be notified of this action.

 
CauseThe installer fails to recognize that informational messages are to be treated as information only messages, and as a condition it is detected and logs this as an error generating an error code during upgrade from 4.1.x to 4.2.0.0 of the ECAT installation.
Documentation in the installation guide advises to turn off the SQL Agent, so this error message is seen despite the fact the installation completes successfully.
ResolutionWhen running a full upgrade, such as from 4.1.2 to 4.2.0 there is an error message generated during installation:
 
SQLServerAgent is not currently running so it cannot be notified of this action.
Error while executing SQL script ECAT_DELTA_4120_LATEST.SQL at line 133


This can be ignored, as the upgrade actually completes successfully anyways. This is because the installer incorrectly treats it as an error, but continues processing the upgrade.
This error by itself will not prevent a successful upgrade of the ECAT database, and can be safely ignored.

Attachments

    Outcomes