000034029 - RSA Live Feed is not updating, getting error "remote server returned an error" in RSA ECAT 4.1.x

Document created by RSA Customer Support Employee on Oct 11, 2016Last modified by RSA Customer Support on Apr 24, 2018
Version 4Show Document
  • View in full screen mode

Article Content

Article Number000034029
Applies ToRSA Product Set: ECAT
RSA Product/Service Type: ECAT
RSA Version/Condition: 4.1.x
Platform: Windows
Product Name: RSA Netwitness Endpoint
IssueYou have successfully configured RSA Live Reputation Services and RSA Live Subscribed Feeds.
The connection is either through a proxy or directly connected to Internet.

However each subscription throws error message akin to "The remote Server returned an error, {407} un-authorized server".

API service is running,(passed all the tests) you are able to connect to the "cms.netwitness.com" website and logon using same credentials as furnished in the Live Feed Configuration page.

Screenshot of Live Feed subscriptions
CauseThis could be due to the ECAT Service account being denied access through web proxy or misconfiguration of the Internet settings for ECAT Service account web browser.
(The API service uses same account as the ECAT Console Service)
In certain cases it could be due to firewall rule that is based on User and Groups.
ResolutionVerify the Proxy server settings are correct.
See KB article #000032967 titled "How to configure proxy access to the RSA ECAT API server" for more details.

Check with the Web proxy team to find out more information how connections are authorized.
If firewall is configured to use user and groups, make sure the ECAT Service account is allowed.

If you are directly connecting to Internet.
Items to check on the ECAT Server

Logon the machine hosting the ECAT Console Service and ECAT API Service as the ECAT service account.
a. Open up Internet Explorer  -> click settings, (or the gear icon) -> right click Internet Options.
b. If there is a home page listed in General settings leave it blank.

Click Connections tab -> Click LAN Settings
Verify that Proxy Server settings are correct, or if going directly to the internet, clear the check box below Proxy Server.
After making any changes click OK -> Click OK

 User-added image