000034374 - RSA Identity Governance and Lifecycle MigrationReports.zip fails to install Migration Reports with ORA-04063: package body "AVUSER.PRE_MIGRATION_PKG" has errors

Document created by RSA Customer Support Employee on Nov 29, 2016Last modified by RSA Customer Support Employee on May 27, 2017
Version 3Show Document
  • View in full screen mode

Article Content

Article Number000034374
Applies ToRSA Product Set: RSA Identity Governance and Lifecycle
RSA Version/Condition: 6.8.1, 6.9, 6.9.1, 7.0.0, 7.0.1, 7.0.2
 
IssueInstalling Migration Reports fails as follows:
$ sh insertMigrationReportDefinitions.sh
Using /home/oracle/Aveksa_System.cfg configuration file to find the target database ...
ORACLE_CONNECTION_ID=AVDB
AVEKSA_USER=avuser
AVEKSA_REPORTS_USER=avdwuser
Provide the password for the user avuser:
Creating required views and reports for migration ...
Package created.
No errors.
Warning: Package Body created with compilation errors.
Errors for PACKAGE BODY PRE_MIGRATION_PKG:
LINE/COL ERROR
-------- -----------------------------------------------------------------
879/2    PL/SQL: Statement ignored
879/22   PLS-00306: wrong number or types of arguments in call to
         'DATABASE'
885/2    PL/SQL: Statement ignored
885/22   PLS-00306: wrong number or types of arguments in call to
         'PRODUCT'

View created.
View created.
View created.
View created.
View created.
View created.
View created.
View created.
View created.
View created.
DECLARE
*
ERROR at line 1:
ORA-04063: package body "AVUSER.PRE_MIGRATION_PKG" has errors
ORA-06508: PL/SQL: could not find program unit being called:
"AVUSER.PRE_MIGRATION_PKG"
ORA-06512: at line 1563
CauseThe package "Pre_Migration_Pkg.pkb" from the MigrationReports.zip utility contains incorrect references.
ResolutionIf you are pre-7.0.0, 7.0.0 or 7.0.2, a new version of the MigrationReports.zip utility has been uploaded to RSA Link.
1. Go to RSA Link -> RSA Identity Governance and Lifecycle -> Downloads.
2. Choose the link to 7.0, 7.0.1, or 7.0.2 depending on the version you are migrating to.
3. Click on the link entitled "RSA Identity Governance and Lifecycle Data Collection Migration Utility."
Please use the latest utility from RSA Link or the attached MigrationReports.zip.
If you are on 7.0.1, this issue has been reported in ACM-75187. There is currently no fix.


 

Attachments

Outcomes