000034432 - When adding or uploading a file to a record in RSA Archer 5.5, an error displays: The page was not displayed because the request entity is too large.

Document created by RSA Customer Support Employee on Dec 9, 2016Last modified by RSA Customer Support Employee on Apr 22, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000034432
Applies ToRSA Product Set: Archer
RSA Version/Condition: 5.5
 
IssueWhen adding or uploading a file to a record in RSA Archer, an error displays: The page was not displayed because the request entity is too large.
User-added image
CauseThe value currently set for uploading file to not big enough for file size.
ResolutionChange the default attributes of ApplicationHost.config file - Default Web Site location section of the file (c:\Windows\System32\Inetsrv\Config)
- Change uploadReadAheadSize in applicationHost.config file for IIS 7 (the default is 48 kilobytes):
- Change maxAllowedContentLength in applicationHost.config file for IIS7.
The size of this value is set in bytes, in the example below we've set both of these values to 10MB which should be sufficient.
It's very likely that these values do not currently exist in your applicationHost.config file so they will need to manually added. We also need to be mindful that these values might already be set as an override in Archer Web.config file. Please take a copy of the original file before making any changes.
------
Before (Will look something similar)
<location path="Default Web Site">
  <system.webServer>
    <security>
      <authentication>
        <anonymousAuthentication enabled="false" />
        <windowsAuthentication enabled="true" />
      </authentication>
      <access sslFlags="SslNegotiateCert" />
    </security>
  </system.webServer>
</location>

After
<location path="Default Web Site">
  <system.webServer>
    <security>
      <authentication>
        <anonymousAuthentication enabled="false" />
        <windowsAuthentication enabled="true" />
      </authentication>
      <access sslFlags="SslNegotiateCert" />
      <requestFiltering>
        <requestLimits maxAllowedContentLength="10485760" />
      </requestFiltering>
    </security>
    <serverRuntime uploadReadAheadSize="10485760" />
  </system.webServer>
</location>

Then perform an IISRESET.

This can also be set in IIS Manager by opening the website and selecting Configuration Editor. You will see a screen similar to the below and you and update the value here.
User-added image

Attachments

    Outcomes