000034160 - How to modify the memory of the RSA Authentication Manager 8.x virtual appliance on VMware

Document created by RSA Customer Support Employee on Jan 31, 2017Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 4Show Document
  • View in full screen mode

Article Content

Article Number000034160
Applies ToRSA Product Set: SecurID
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.x
Platform: VMware
IssueThis article explains how to modify the memory size of an RSA SecurID Appliance running RSA Authentication Manager 8.x software on VMware.
ResolutionThe provisioning of a VMware Authentication Manager instance is by default 8 GB of memory. The VMware primary or Rreplica instance hardware requirements on page 15 of the RSA Authentication Manager 8.1 Setup and Configuration Guide state that the minimum memory requirement for a VMware primary or replica instance can be 4 GB or an administrator can increase the memory value to 16 GB, where resources are available.

Steps to perform the memory change


  1. Schedule downtime of the Authentication Manager instance where the memory settings require a change.
  2. SSH to the Authentication Manager instance as the rsaadmin user.
  3. Shutdown the Authentication Manager services and OS with the commands:

/opt/rsa/am/server/rsaserv stop all
sudo shutdown -y -g0 -i0


  1. Logon to the vSphere Client used to manage the VMware environment.
  2. Right-click the host representing the Authentication Manager instance.
  3. Select Edit Settings...
User-added image

  1. On the Hardware tab, select Memory and change the Memory Size as desired; e. g., 4 GB or 16 GB.
User-added image

  1. Click OK.
  2. Power on the VMware primary or replica instance in the vSphere Client by selecting the machine and selecting Power > Power On.
User-added image

  1. After the VMware primary or replica instance is powered up, logon to either the local console, or via an SSH client, as rsaadmin and check that the Authentication Manager services are listed as RUNNING with the command:
    /opt/rsa/am/server/rsaserv status all

NotesChanging the memory settings for the virtual SecurID Appliance from 8 GB to 4 GB is not advisable for production environments. Should a technical problem be experienced with the VMware primary or replica instance after the memory requirement is changed or later on, then before opening a case with RSA Customer Support please change the memory setting back to 8 GB to see if this resolves the problem.

Attachments

    Outcomes