Introducción de hosts: Solución de advertencias, conflictos y errores previos a la actualización y durante la actualización a 10.6

Document created by RSA Information Design and Development on Feb 9, 2017
Version 1Show Document
  • View in full screen mode
  

Esta sección contiene los mensajes de error de la comprobación previa a la actualización y la actualización de la Vista Hosts de 10.6.0, con una descripción de cada mensaje e instrucciones para responder a ellos.

Advertencias previas a la actualización

Las advertencias previas a la actualización son anomalías o posibles problemas en la configuración actual que no impiden la actualización a la versión nueva. Si Security Analytics encuentra un posible problema, muestra Advertencia de actualización. Ver detalles en la columna Estado de la vista Hosts. Haga clic en Ver detalles para mostrar el mensaje completo. 

               
Advertencia
Mensaje

Advertencia previa a la actualización
Revise lo siguiente antes de actualizar.

  1. La versión del kernel en el host es más antigua que la versión 2.6.32-504.1.3 compatible con Security Analytics. Si hace clic en Iniciar actualización, se instalará el kernel versión 2.6.32-504.1.3 en el host.
  2. Después de la actualización a 10.6.0.0, las reglas de correlación escritas en sintaxis obsoleta pueden hacer que el Concentrator se inicie en un estado fallido. Las reglas que coinciden con el formato estricto no causan este problema.
    Para obtener más información, consulte el tema de la ayuda en línea de Security Analytics 10.6 “Guía de reglas y consultas”.
Causa
  1. El kernel CentOS en el host es más antiguo que el kernel compatible con la versión de actualización que seleccionó.
  2. Si este host es un Concentrator y se inicia en un estado fallido, es posible que existan reglas de correlación escritas en sintaxis obsoleta. 

Nota: Estado actual muestra la versión actual de Security Analytics/sistema operativo del host antes de la actualización a 10.6.  

Recomendado
Acción
  1. Haga clic en Iniciar actualización en el cuadro de diálogo de advertencia para instalar el kernel compatible.
  2. Asegúrese de que las reglas correlacionadas se ajusten al formato estricto, como se describe en el tema Guía de reglas y consultas de la Guía de configuración de Archiver.

Conflictos previos a la actualización

Los conflictos previos a la actualización son problemas en la configuración actual o en el repositorio de actualización local que impiden la actualización a la versión nueva. Si Security Analytics encuentra:

  • Ajustes de configuración incompatibles, muestra Conflicto de actualización. Ver detalles en la columna Estado
  • Problemas al descargar los archivos de actualización de la versión, muestra Error de descarga. Ver detalles en la columna Estado.

Para obtener información adicional sobre el repositorio de actualización local, consulte el tema Completar el repositorio de actualización local de la guía Mantenimiento del sistema.

               
Conflict
Mensaje

Error de descarga
La descarga falló debido a los siguientes errores.

Error al configurar los repositorios: No se pueden recuperar los metadatos del repositorio (repomd.xml) para el repositorio: SA. Compruebe su ruta y vuelva a intentarlo.

Causa Security Analytics no se puede conectar con el repositorio de actualización de Live desde el cual RSA distribuye las actualizaciones de versión desde el repositorio de actualización de RSA Live a través de su conexión de Live.
Recomendado
Acción

Asegúrese de que:

  1. Configurar los servicios de Live. Para obtener más información, consulte el tema Configurar los servicios de Live en Security Analytics de la guía Administración de servicios de Live.
  2. Haber seleccionado la casilla de verificación Conectarse al repositorio de actualización de Live en Administration > Sistema > pestaña Actualizaciones.

 

               
Descarga
Error
Mensaje

Error de descarga
La descarga falló debido a los siguientes errores.

El repositorio de actualización local no tiene actualizaciones válidas.  Consulte Completar el repositorio de actualización local para obtener instrucciones acerca de cómo obtener actualizaciones válidas.

Causa Security Analytics no encontró la actualización de versión que usted seleccionó en el repositorio de actualización local.
Recomendado
Acción
Revise las instrucciones sobre cómo Completar el repositorio de actualización local e intente completar el repositorio local con la versión de actualización que desea. Consulte el tema Completar el repositorio de actualización local en la guía Mantenimiento del sistema. Si no puede resolver este conflicto después de revisar estas instrucciones, póngase en contacto con Atención al cliente.

 

               
Conflict
Mensaje

Error de comprobación previa a la actualización
La actualización no se puede iniciar.
Resuelva los siguientes errores y vuelva a intentarlo.

Comprobación del sistema de archivos fallida
Espacio insuficiente en la partición /var/lib/rabbitmq.
El espacio utilizado para esta partición debe ser menor que el 80 %.
Estado actual: percentage-used %

Causa Los mensajes se acumulan en la partición /var/lib/rabbitmq .
Recomendado
Acción

Investigue por qué los mensajes se acumulan en la partición y resuelva este problema. Si no puede resolver este problema, póngase en contacto con Atención al cliente.

 

               
Conflict
Mensaje

Error de comprobación previa a la actualización
La actualización no se puede iniciar.
Resuelva los siguientes errores y vuelva a intentarlo.

La versión del kernel en el host es más reciente que la versión 2.6.32-504.1.3 compatible con Security Analytics. Contacto con Atención al cliente

Causa No puede actualizar a la versión que eligió porque la versión del kernel en el host es más reciente que la versión 2.6.32-504.1.3 compatible con Security Analytics para esa versión.
Recomendado
Acción

 Póngase en contacto con Atención al cliente para resolver el problema. 

 

               
Conflict
Mensaje

La ruta de actualización no es compatible
La ruta de actualización a selected-update-version es:

  • version-range
  • version-range
  •            .
  •            .
  •            .             

Precaución:

  1. Si está ejecutando la versión 9.8, póngase en contacto con el servicio al cliente para obtener instrucciones de actualización.
  2. Si está ejecutando la versión 10.3.x, debe actualizar a 10.4.1 antes de poder actualizar a 10.6.x.x.  Consulte la Guía de actualización de RSA Security Analytics 10.4.1 en SCOL (https://knowledge.rsasecurity.com/) para obtener instrucciones detalladas sobre la actualización de 10.3.x a 10.4.1 (si usa Event Stream Analysis en 10.3.x, debe migrar sus reglas a 10.4.1). No puede acceder a los RPM de actualización de 10.4.1 desde el repositorio de actualización de Live. Esto significa que debe descargar los RPM de actualización de 10.4.1 desde SCOL.
Causa

La versión en el host no es compatible como una ruta de actualización para la versión de actualización que eligió.  

Recomendado
Acción
Actualice el host a una ruta compatible.

Errores de actualización

Los errores de actualización son errores que detienen el proceso de actualización. Si Security Analytics encuentra un error de actualización, muestra Error de actualización. Ver detalles en la columna Estado de la vista Hosts. Haga clic en Ver detalles para abrir uno de los siguientes cuadros de diálogo de errores de actualización:

               
Error Message

El sistema no recibió la respuesta prevista

Causa

Security Analytics no puede identificar el estado del host debido a que existe un archivo 
/var/lib/puppet/state/agent_catalog_run.lock en el host.

Cuando se ejecuta el agente puppet, este crea un archivo de bloqueo llamado 
agent_catalog_run.lock. En ocasiones, este archivo de bloqueo está presente en el host, a pesar de que el agente puppet no está en ejecución.

Recomendado
Acción

Intente una de las siguientes acciones para resolver el error:

  • Quite el archivo /var/lib/puppet/state/agent_catalog_run.lock del host.
  • Compruebe la hora en los hosts que no son de servidor de Security Analytics y en el host del servidor de Security Analytics y asegúrese de que esté sincronizada.
  • Vuelva a intentar la actualización en otro momento. Si falla, póngase en contacto con Atención al cliente para resolver el problema.
You are here
Table of Contents > Solucionar problemas de actualizaciones de hosts > Solución de advertencias, conflictos y errores previos a la actualización y durante la actualización a 10.6

Attachments

    Outcomes