Investigation:Investigationプロファイルを使用したカスタム ビューのカプセル化

Document created by RSA Information Design and Development on Feb 16, 2017Last modified by RSA Information Design and Development on Feb 16, 2017
Version 2Show Document
  • View in full screen mode
  

このトピックでは、アナリストが[ナビゲート]ビューおよび[イベント]ビューに対する一連のInvestigation環境設定を定義するプロファイルを使用する方法について説明します。

プロファイルを使用することにより、Investigationに表示するデータを迅速かつ簡単にカスタマイズできます。[プロファイルの管理]ダイアログでは、プロファイルを使用して、デフォルトで表示されるメタ グループおよび列グループを指定したり、調査にクエリーを追加したり、プロファイルをインポートまたはエクスポートしたりできます。

注:プロファイルは、同じSecurity Analyticsネットワーク内のユーザー間で共有されます。あるユーザーがプロファイルを変更または削除すると、その他のユーザーにも影響を与えます。

複数のプロファイルがある場合は、それらを切り替えて、選択したプロファイルの環境設定にすばやく変更できます。プロファイルがアクティブな場合は、[プロファイル]メニューのタイトルにそのプロファイルの名前が表示されます。

次の図は、[ナビゲート]ビューでのタイトル表示を示しています。プロファイル名が[クエリー]と[メタ]の間に表示されています。

NavVwTb.png

次の図は、[イベント]ビューでのタイトル表示を示しています。プロファイル名が[クエリー]とリスト ビューの間に表示されています。

EvTbProf.png

[プロファイルの管理]ダイアログに移動します。

  1. Security Analyticsメニューで、[Investigation]>[ナビゲート]、または[Investigation]>[イベント]を選択します。
  2. Investigate]ダイアログが表示される場合は、サービスを選択して[ナビゲート]をクリックします。
  3. ツールバーで、[プロファイル]>[プロファイルの管理]を選択します。
    [プロファイルの管理]ダイアログが表示されます。
    ManProfDg.png

プロファイルの作成および編集

  1. プロファイルの管理]ダイアログで、名前の横にあるチェックボックスをオンにして既存のプロファイルを選択するか、または[追加]アイコンをクリックして新しいプロファイルを作成します。
    右側のパネルが使用可能になります。
  2. 名前]フィールドで、プロファイル名を編集または入力します。名前は2~80文字の長さにする必要があります。
  3. メタ グループ]ドロップダウン リストからメタ グループを選択します。次のトピックでの説明に従って、カスタム メタ グループを追加することができます。ユーザー定義のメタ グループの管理.
  4. 列グループ]ドロップダウン リストから列グループを選択します。次のトピックでの説明に従って、カスタム列グループを追加することができます。  [イベント]ビューでの列グループの管理.
  5. 結果をフィルタリングするためのクエリーを[プレ クエリー]フィールドに入力します。プレ クエリーの構文はクエリー ビルダーと同じです。図のプレ クエリーでは、crypto existsというクエリーを記述しています。
  6. プロファイルを使用せずに保存するには[保存]をクリックし、プロファイルを保存してただちに使用するには[保存して適用]をクリックします。
    保存して適用]をクリックすると、選択したプロファイルをアクティブにする前に確認ダイアログが表示されます。

アクティブ プロファイルの変更

[ナビゲート]ビューまたは[イベント]ビューに十分な結果または正しい結果が表示されない場合は、別のプロファイルをアクティブに設定できます。プロファイルを使用しない場合は、[プロファイル]ドロップダウン メニューの[プロファイルの非アクティブ化]をクリックします。

別のプロファイルを使用する方法

  1. ナビゲート]ビューまたは[イベント]ビューのツールバーで、[プロファイル]ドロップダウン メニューを開きます。
  2. プロファイル]オプションにマウス ポインターを置くと、使用可能なプロファイルのドロップダウン リストが表示されます。
  3. 使用するプロファイルを選択します。
    そのプロファイル設定が即座に適用されます。

[プロファイルの管理]ダイアログでアクティブ プロファイルを変更する方法

  1. ナビゲート]ビューまたは[イベント]ビューのツールバーで、[プロファイル]>[プロファイルの管理]を選択します。
    [プロファイルの管理]ダイアログが表示されます。
  2. 左側のパネルでプロファイルを選択し、[保存して適用]をクリックします。
    確認ダイアログが表示されます。
  3. はいをクリックします。
    そのプロファイル設定が即座に適用されます。

プロファイルのインポート

別のサービスからダウンロードした.jsnファイルをアップロードまたはインポートできます。

  1. プロファイルの管理]ダイアログで、左側のパネルのツールバーにあるImport.pngをクリックします。
  2. [プロファイルのインポート]ダイアログが表示されます。
  3. 参照]または[ファイルのアップロード]フィールドをクリックして、コンピュータ上のファイルを選択します。
  4. ファイルを選択したら、[アップロード]をクリックします。
    アップロードしたプロファイルが左側のパネルに表示されます。

プロファイルのダウンロード

プロファイルは.jsnファイルとしてダウンロードできます。

  1. プロファイルの管理]ダイアログで、左側のパネルから1つまたは複数のプロファイルを選択します。
  2. 左側のパネルのツールバーでExport.pngをクリックします。
    ダウンロードがすぐに始まります。
You are here
Table of Contents > 調査の実施 > [ナビゲート]ビューでの情報のフィルタ > Investigationプロファイルを使用したカスタム ビューのカプセル化

Attachments

    Outcomes