000034910 - How to determine what version of RSA Authentication Agent for Web for Apache is installed

Document created by RSA Customer Support Employee on Mar 7, 2017
Version 1Show Document
  • View in full screen mode

Article Content

Article Number000034910
Applies ToRSA Product Set: SecurID
RSA Product/Service Type: Authentication Agent for Web for Apache
RSA Version/Condition: 8.0
Platform: Red Hat Enterprise Linux
 
IssueAn administrator needs to determine which version of RSA Authentication Agent for Web for Apache is installed.
ResolutionWhere the LogLevel in the Apache configuration (httpd.conf) is set to debug the Apache and RSA Web Agent will report their version numbers in the Apache error_log when the Apache Web Server is restarted.
 
NOTE: To set the LogLevel to debug, an administrator would need to make the change to the httpd.conf file and restart the Apache Web Server processes.  An example extract from httpd.conf is shown here:

..
..
#
# LogLevel: Control the number of messages logged to the error_log.
# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
#
LogLevel debug
..
..


 
Example debug data showing the version information of Apache and the RSA web agent, taken from the error_log:

..
..
[Tue Mar 07 14:41:38 2017] [notice] Apache/2.2.15 (Unix) mod_rsawebagent/8.0.0[399] DAV/2 configured -- resuming normal operations
rpc_server 475 started by 464
..
..

Attachments

    Outcomes