000034930 - Apache Struts 2 Jakarta Multipart Parser File Upload Code Execution Vulnerability (CVE-2017-5638) in RSA Products

Document created by RSA Link Team Employee on Mar 13, 2017Last modified by RSA Product Team on Oct 11, 2017
Version 10Show Document
  • View in full screen mode

Article Content

Article Number000034930
Applies ToRSA Product Set: All RSA Products
CVE IDCVE-2017-5638
Article SummaryOn March 6, 2017, Apache disclosed a vulnerability in the Jakarta multipart parser used in Apache Struts 2 that could allow an attacker to execute commands remotely on the targeted system using a crafted Content-Type header value. The details for this vulnerability can be found at https://cwiki.apache.org/confluence/display/WW/S2-045.
ResolutionRSA is aware of and investigating this issue to identify the product impact. The level of impact may vary depending on the affected product. The following table contains the latest available impact information. This table will be updated as additional information becomes available.
 
RSA Product NameVersionsImpacted?DetailsLast Updated
3D Secure / Adaptive Authentication eCommerceAll Supported Not Impacted  2017-03-13
Access Manager6.2, 6.2.1, 6.2.2, 6.2.3, 6.2.4ImpactedRefer to the security advisory ESA-2017-038 on RSA Link. Hotfix 6.2.4.04 with a fix for this issue, is available for RSA Access Manager 6.2.4. For other affected versions, hotfixes are being worked on. See KB 000034968 for remedial steps where hotfix is not yet available.2017-03-28
Adaptive Authentication Hosted11, 12Not Impacted 2017-03-13
Adaptive Authentication On-Prem7.xNot ImpactedProduct does not use impacted version of Apache Struts2017-03-13
Archer HostedN/ANot Impacted 2017-03-13
Archer PlatformAll SupportedNot Impacted 2017-03-11
Archer SecOpsAll SupportedNot Impacted 2017-03-11
Archer Vulnerability & Risk Manager (VRM)All SupportedNot Impacted 2017-03-13
Authentication Manager8.1, 8.1SP1, 8.2, 8.2SP1Not Impacted 2017-03-11
Authentication Manager Appliance8.1, 8.1SP1, 8.2, 8.2SP1Not Impacted 2017-03-11
BSAFE C Products: MES, Crypto-C ME, SSL-CAll SupportedNot ImpactedBSAFE products do not use Apache Struts.2017-03-14
BSAFE Java Products: Cert-J, Crypto-J, SSL-JAll SupportedNot ImpactedBSAFE products do not use Apache Struts. 2017-03-14
Data Loss PreventionAll SupportedNot Impacted 2017-03-11
Data Protection Manager3.5.2.5Impacted - RemediatedThis issue is fixed in RSA DPM 3.5.2.5.1 (see ESA-2017-037). All other versions prior to 3.5.2.5 are NOT impacted.2017-04-10
DCS: Certificate ManagerAll SupportedNot ImpactedProduct does not use Apache Struts.2017-03-14
DCS: Validation ManagerAll SupportedNot ImpactedProduct does not use impacted version of Apache Struts2017-03-14
ECAT (NetWitness Endpoint)All SupportedNot Impacted 2017-03-11
eFraudNetwork (eFN)All Supported   
enVisionEOPSNot ImpactedProduct does not use Struts.2017-03-14
Federated Identity ManagerAll SupportedNot Impacted 2017-03-15
FraudAction (OTMS)All SupportedNot Impacted 2017-03-16
Identity Governance and Lifecycle Software
(Via Lifecycle and Governance Software, Identity Management & Governance Software)
All SupportedNot ImpactedProduct does not use impacted version of Apache Struts2017-03-13
Identity Governance and Lifecycle Appliance
(Via Lifecycle and Governance Appliance, Identity Management & Governance Appliance)
All SupportedNot ImpactedProduct does not use impacted version of Apache Struts2017-03-13
Identity Governance and Lifecycle SaaS / MyAccessLive
(Via Lifecycle and Governance SaaS / MyAccessLive)
All SupportedNot ImpactedProduct does not use impacted version of Apache Struts2017-03-15
RSA CentralAll Supported   
RSA Live InfrastructureAll Supported Not Impacted  2017-03-13
SecurID Access SuiteAll SupportedNot Impacted 2017-03-11
SecurID Agent for PAMAll SupportedNot Impacted 2017-03-11
SecurID Agent for WebAll SupportedNot Impacted 2017-03-11
SecurID Agent for WindowsAll SupportedNot Impacted 2017-03-11
SecurID Authentication EngineAll SupportedNot Impacted 2017-03-11
SecurID Authentication SDKAll SupportedNot Impacted 2017-03-11
SecurID Software Token ConverterAll SupportedNot Impacted 2017-03-11
SecurID Software Token for AndroidAll SupportedNot Impacted 2017-03-11
SecurID Software Token for BlackberryAll SupportedNot Impacted 2017-03-11
SecurID Software Token for DesktopAll SupportedNot Impacted 2017-03-11
SecurID Software Token for iPhoneAll SupportedNot Impacted 2017-03-11
SecurID Software Token for Windows MobileAll SupportedNot Impacted 2017-03-11
SecurID Software Token ToolbarAll SupportedNot Impacted 2017-03-11
SecurID Software Token Web SDKAll SupportedNot Impacted 2017-03-11
SecurID Transaction Signing SDKAll SupportedNot Impacted 2017-03-15
Security Analytics
   (Physical and Virtual Appliances)
All SupportedNot Impacted 2017-03-11
Via Access IDR VM (SecurID Access Suite)All SupportedNot Impacted 2017-03-11
Via Access Cloud Service (SecurID Access Suite)All SupportedNot Impacted 2017-03-11
Web Threat DetectionAll SupportedNot Impacted  2017-03-13
NotesFor status of Dell products, see: http://www.dell.com/support/article/us/en/19/SLN305421
For status of Dell EMC products, see: https://support.emc.com/kb/497237
For status of VCE products, see: https://na7.salesforce.com/knowledge/publishing/articleOnlineDetail.apexp?id=kA2A00000004eyP

 

Disclaimer

Read and use the information in this RSA Security Advisory to assist in avoiding any situation that might arise from the problems described herein. If you have any questions regarding this product alert, contact RSA Software Technical Support at 1- 800 995 5095. RSA Security LLC and its affiliates, including without limitation, its ultimate parent company, EMC Corporation, distributes RSA Security Advisories in order to bring to the attention of users of the affected RSA products, important security information. RSA recommends that all users determine the applicability of this information to their individual situations and take appropriate action. The information set forth herein is provided 'as is' without warranty of any kind. RSA disclaims all warranties, either express or implied, including the warranties of merchantability, fitness for a particular purpose, title and non-infringement. In no event, shall RSA, its affiliates or suppliers, be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if RSA, its affiliates or suppliers have been advised of the possibility of such damages. Some jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental damages, so the foregoing limitation may not apply.

1 person found this helpful

Attachments

    Outcomes