000034824 - Jetty Server crashes when the PAM auth for SecureID configuration setup is not fully completed in RSA NetWitness

Document created by RSA Customer Support Employee on Mar 16, 2017Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000034824
Applies To
RSA Product Set: Netwitness
   RSA Product/Service Type: Security Analytics Server
   RSA Version/Condition:10.4 and above 
   Platform: CentOS
IssueJetty server crashes  while setting up PAM agent for SecureID which lead to inability to access SA web interface.

Steps to configure PAM agent for SecureID are documented in below link:-
https://community.rsa.com/docs/DOC-63643


While performing step 8 in 2.b(Installing the PAM SecureID Module) during the setup, this will cause jetty to crash if the setup isn't completed. 
8. Edit the Security Analytics server PAM configuration file, /etc/pam.d/securityanalytics by adding this line:
auth required pam_securid.so
If the file does not exist, create it and add this line:
auth sufficient pam_securid.so
 
CauseThis issue is related to the file located at /etc/pam.d/securityanalytics which needs to be modified while performing step 2.b  causing SA GUI accessibility issue because customer doesn't have PAM fully setup yet and document steps do not show/inform that it would break all of authentication until the set up is fully completed.
 
ResolutionOnce the PAM configuration set up is complete, issue gets resolved automatically. 
Note: It may require to restart jetty service using below commands on SA Server:-
#stop jettysrv
#start jettysrv
 

Attachments

    Outcomes