000035938 - After clicking Search button for Advanced Search in RSA Archer, an unexpected error occurs if page is idle for 1 - 2 minutes

Document created by RSA Customer Support Employee on Jan 23, 2018
Version 1Show Document
  • View in full screen mode

Article Content

Article Number000035938
Applies ToRSA Product Set: Archer
RSA Product/Service Type: RSA Archer (On-Premise)
RSA Version/Condition: 6.2 P2 HF1, 6.2 P3, 6.2 P4, 6.2 P5, 6.2 P6, 6.2 P7, 6.2 P8, 6.3 P1 HF1 and 6.3 P2
Platform: Windows
IssueAfter creating or opening an existing report and approximately 1:20 seconds to 2 minutes of waiting while idle or moving the cursor and clicking and fields to maintain activity and then clicking the Search button the "unexpected error has occurred in the system. Please try your request again. If the problem persists, please contact your system administrator" is displaying.
 

User-added image

This is issue occurs in the following environment
  1. Standard Archer install (No SSL and No SSO). Search issue IS NOT reproducible.
  2. Enable/Disable SSL. Search issue IS NOT reproducible.
  3. Enable SSO. Search issue IS reproducible.
CauseInternet Explorer is designed to perform NTLM Pre-authentication and exclude the POST request payload because they aren't required to complete NTLM authentication successfully. At this point, if the server doesn’t challenge Internet Explorer for authentication but instead expects the POST request payload to be delivered, the underlying web application may not work as expected.
For more details, check out https://support.microsoft.com/en-us/help/251404/you-cannot-post-data-to-a-non-ntlm-authenticated-web-site.  
The issue is commonly seen in cases where the Web Application is configured for mixed mode Authentication like Archer.
ResolutionPerform the following steps on each workstation:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and select the following registry subkey: 

    HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Internet Settings/

  3. In the right pane, right-click to open the context menu and select New > DWORD (32-Bit) Value.
  4. For Name, enter DisableNTLMPreAuth.
  5. Right-click DisableNTLMPreAuth and select Modify.
  6. For Value data, enter 1.
  7. Restart workstation for new settings to take effect.
  8. Clear the cache and try it again.
User-added image
Workaround
 
NotesThe issue IS also reproducible through manual login on the same setup.
This issue IS NOT reproducible using the supported version of Firefox (version 48 - 64-bit).
For more information about this issue, please check ARCHER-42852.

Attachments

    Outcomes