000035860 - RSA NetWitness Logs & Network shows the error message "update path unsupported" on the hosts page

Document created by RSA Customer Support Employee on Jan 25, 2018Last modified by RSA Customer Support Employee on Mar 7, 2019
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000035860
Applies ToRSA Product Set: RSA NetWitness Logs & Network
RSA Product/Service Type: Security Analytics Server
RSA Version/Condition: 10.6.x.x
Platform: CentOS
 
IssueUnable to upgrade host correctly provisioned through the RSA NetWitness UI, due to the host displaying the following error message: "upgrade path unsupported." 
CauseThis is caused by an inconsistency with the puppet mongo database concerning hosts and repository information. 
Resolution
  1. SSH to the RSA NetWitness UI server node with "root" access. 
  2. Flush incorrect update data from the puppet databases and reset the repository: 

  • Access the puppet database and clean the associated host-upgrade tables using the following commands:


# mongo puppet
> db.appliance_update.drop()
> db.host_manifest.drop()
> db.repos.drop()
> exit


  • Reset the repository:


# cd /var/netwitness/srv/www/rsa/updates
# rm -rf *


  • Upload the 10.6.4 files or the required target-release via the RSA NetWitness UI.

Attachments

    Outcomes