000036010 - Error message when publishing update to a Linux or macOS agent via the RSA NetWitness Endpoint UI

Document created by RSA Customer Support Employee on Mar 24, 2018
Version 1Show Document
  • View in full screen mode

Article Content

Article Number000036010
Applies ToRSA Product Set: NetWitness Endpoint
RSA Product/Service Type: User Interface, Agent
RSA Version/Condition: 4.4.0.2, 4.4.0.1, 4.4.0.0, 4.3.x
Platform: Linux, macOS
 
IssueWhen updating an endpoint Linux or macOS agent via the RSA NetWitness Endpoint user interface, the error message below is displayed after selecting the package.

The file properties are not shown, because the file does not meet the requirement.


sreenshot of selected package and error messsage
CauseThis condition is a result of the file permissions on the agent package.
Local administrators have full control of the file. Local Users have Read & Execute and Read permissions.
Even if the RSA NetWitness Endpoint user is member of the domain admins group, the effective permissions will be the same for local user account.
ResolutionThis Issue has been resolved in RSA NetWitness Endpoint 4.4.0.3.
WorkaroundThere are two workarounds for the issue:
  • Add the Endpoint User to the local administrators group
  • As a local administrator, check the "write box for agent package" option.

Attachments

    Outcomes