000035978 - Checking name resolution and port connectivity for an RSA Authentication Manager 8.1 SP1 or later Web Tier instance on a supported Red Hat platform

Document created by RSA Customer Support Employee on May 29, 2018Last modified by RSA Customer Support Employee on May 29, 2018
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000035978
Applies ToRSA Product Set: SecurID
RSA Product/Service Type: Authentication Manager Web Tier
RSA Version/Condition: 8.1 SP 1 or later
 
IssueThe Authentication Manager primary instance is reporting a status other than Online for a web tier deployment running on supported Red Hat platforms.  For example, Offline, Pending Connection or Reinstall Required, and further investigation is required.
ResolutionThe shell script attached to this article will attempt to find the Web Tier installation directory, as well as look up the Authentication Manager, Web Tier and Virtual Host fully qualified host names from the Web Tier configuration. Next, the shell script will perform name resolution of the fully qualified host names and check the status of ports 7022/TCP and the virtual host port, which by default is 443/TCP.

Installation



  1. Download the attached wtcheck.sh shell script into the /tmp folder on a Web Tier instance that is running on a supported Red Hat platform.
  2. Change the permissions of wtcheck.sh so it can be executed at the command line:


chmod 755 /tmp/wtcheck.sh


Usage



  1. Logon to the Red Hat platform with a local account, either in an SSH session or at the local console.
  2. Change the privileges of the local account using the command sudo su -.


rsaadmin@am82p:/opt/rsa/am> sudo su -
rsaadmin's password: <enter operating system password>
am82p:~ #


If you do not change the privileges of the local account, then the following message appears: You must be the root user to use this program; exiting...



  1. Navigate to the /tmp directory:


cd /tmp


  1. Use the wtcheck.sh shell script to check name resolution and port accessibility:  


./wtcheck.sh


  1. To redirect the output from wtcheck.sh into a text file to generate a report, run he following:


 ./wtcheck.sh > /tmp/wtreport.txt

Example output:will be in the following format:


[root@webtier01-csau-ap-rsa-net tmp]# ./wtcheck.sh

Hostname Lookup testing..

Authentication Manager Instance : app82p.csau.ap.rsa.net [1]
Server:         192.168.31.35
Address:        192.168.31.35#53

Name:   app82p.csau.ap.rsa.net
Address: 192.168.31.51


  - lookup worked!

Authentication Manager Instance : app82r.csau.ap.rsa.net [2]
Server:         192.168.31.35
Address:        192.168.31.35#53

Name:   app82r.csau.ap.rsa.net
Address: 192.168.31.52


  - lookup worked!

Web Tier Instance : webtier01.csau.ap.rsa.net [1]
Server:         192.168.31.35
Address:        192.168.31.35#53

Name:   webtier01.csau.ap.rsa.net
Address: 192.168.31.24


  - lookup worked!

Virtual Host Instance : virtualhost.csau.ap.rsa.net [1]
Server:         192.168.31.35
Address:        192.168.31.35#53

Name:   virtualhost.csau.ap.rsa.net
Address: 192.168.31.24


  - lookup worked!

..done!

Checking Ports...(8 second timeout for each check)..

Current hostname : webtier01-csau-ap-rsa-net

Determing the Virtual Host port as : 443

  - Port 7022/TCP is reachable on app82p.csau.ap.rsa.net

  - Port 7022/TCP is reachable on app82r.csau.ap.rsa.net

  - Port 443/TCP is reachable on webtier01.csau.ap.rsa.net

  - Port 443/TCP is reachable on virtualhost.csau.ap.rsa.net

..done!

[root@webtier01-csau-ap-rsa-net tmp]#


 
NotesPage 57 of the RSA Authentication Manager 8.2 SP1 Setup and Configuration Guide provides information on supported Red Hat Enterprise Linux operating systems.

Red Hat Enterprise Linux version 7.4 is now supported with RSA Authentication Manager 8.2 SP1 Patch 7 Web Tier software.  Refer to page 2 of the RSA Authentication Manager 8.2 SP1 Patch 7 Web-Tier Readme.

Attachments

Outcomes