調査:プロファイルを使用したカスタム ビューのカプセル化

Document created by RSA Information Design and Development Employee on Oct 19, 2018Last modified by RSA Information Design and Development Employee on Apr 29, 2019
Version 2Show Document
  • View in full screen mode
 

プロファイルを使用すると、[ナビゲート]ビューと[イベント]ビューに表示されるデータをすばやく簡単にカスタマイズできます。[プロファイルの管理]ダイアログでは、プロファイルを使用して、デフォルトで表示されるメタ グループおよび列グループを指定したり、調査にクエリを追加したり、プロファイルをインポートまたはエクスポートしたりできます。

注:プロファイルは、同じNetWitness Platformネットワーク内のユーザ間で共有されます。あるユーザがプロファイルを変更または削除すると、その他のユーザにも影響を与えます。

複数のプロファイルがある場合は、それらを切り替えて、選択したプロファイルの環境設定にすばやく変更できます。プロファイルがアクティブである場合は、[プロファイル]メニューのタイトルがそのプロファイル名で置き換えられます。

次の図は、[ナビゲート]ビューでのタイトル表示を示しています。プロファイル名は、[クエリ]オプションの右側に表示されます。これは、[イベント]ビューにも当てはまります。

Profile Name to the right of the Query option

バージョン11.2以降では、プロファイルはプロファイル グループに編成されています。ビルトイン プロファイルは、[デフォルト プロファイル]グループにあり、編集できません。アナリストは新しいプロファイル グループを作成でき、だれでも使用できます。作成後、プロファイル グループを編集してプロファイルを追加したり、プロファイルを削除したり、プロファイルを別のグループに移動したりできます。プロファイルを作成しても、デフォルトではプロファイル グループには追加されません。プロファイルをエクスポートすると、プロファイル グループに関する情報が保存され、プロファイルがエクスポート元のグループにインポートされます。

[プロファイルの管理]ダイアログに移動します。

  1. 調査>[イベント]または調査>[ナビゲート]に移動します。([調査]ダイアログが表示されている場合は、サービスを選択して[ナビゲート]をクリックします。)
  2. ツールバーで、[プロファイル]>[プロファイルの管理]を選択します。
    the Manage Profiles option selected
    [プロファイルの管理]ダイアログが表示されます。

プロファイル グループの作成、編集、削除(バージョン11.2以上)

カスタム プロファイル グループを作成して、異なるプロファイルを整理することができます。作成後、プロファイル グループに対して直接行える編集は、プロファイル グループの名前の編集だけです。グループ内のプロファイルを追加または削除するには、プロファイルを編集し、「プロファイルの作成および編集」の説明に従って、別のプロファイル グループに割り当てます。

  1. プロファイルの管理]ダイアログで、次のいずれかを実行します。

    • 編集する既存のプロファイル グループを選択するには、プロファイル グループをダブル クリックします。
    • 新しいプロファイル グループを追加するには、Add iconをクリックして、[新しいプロファイル グループの追加]を選択します。

    注:ビルトイン プロファイル グループのいずれかを編集する場合は、the duplicate iconをクリックして、編集可能なコピーを作成します。

    空白のフィールドがあるフォルダは、左側の列のプロファイル リストの下部に表示されます。
    the Profile Group Name entry field

  2. プロファイル グループの名前を編集または入力するには、プロファイル グループをダブル クリックし、入力フィールドに入力します。名前は2~80文字の長さにする必要があります。
    プロファイルグループ名は、新しいプロファイル グループまたは編集したプロファイル グループに適用されます。プロファイルを設定するときに、プロファイル グループを使用できるようになります。
  3. プロファイル グループを削除するには、次のいずれかの操作を行います。
    • プロファイルを保持したままプロファイル グループを削除する場合は、グループを選択するチェックボックスをオンにし、グループ内のプロファイルのチェックボックスをオフにして、[削除] をクリックします。
    • プロファイル グループおよびグループに含まれるプロファイルを削除する場合は、グループを選択するチェックボックスをオンにし、削除するグループ内のプロファイルのチェックボックスはオフにしません。
      グループの削除を確認するダイアログ ボックスが表示されます。プロファイルの横にあるチェックボックスをオフにしていない場合、グループとグループ内のプロファイルは削除されます。プロファイルのチェックボックスをオフにした場合、プロファイル グループのみが削除され、プロファイルはグループ外に移動されて、別のプロファイル グループに追加することができます。

プロファイルの作成および編集

  1. プロファイルの管理]ダイアログで、次のいずれかを実行します。

    • 編集する既存のプロファイルを選択するには、名前の横にあるチェックボックスをオンにします。
    • バージョン11.2以降で新しいプロファイルを追加するには、Add iconをクリックするか、Add iconの横にある下向き矢印をクリックし、[新しいプロファイルの追加]を選択します。
    • 11.2より前のバージョンで新しいプロファイルを作成するには、Add iconをクリックします。

    注:組み込みプロファイルのいずれかを編集する場合は、the duplicate iconをクリックしてコピーを作成し、コピーを編集します。

    プロファイルの定義は、右側のパネルで編集できます。この図は、ビルトイン プロファイルの1つの定義を示しています。
    the properties of an out-of-the-box profile

  2. 名前]フィールドで、プロファイル名を編集または入力します。名前は2~80文字の長さにする必要があります。
  3. (バージョン11.2以上のオプション)プロファイルをプロファイル グループに追加する場合は、[プロファイル グループ]ドロップダウン リストからプロファイル グループを選択します。
    プロファイル グループを選択すると、変更を保存するときにプロファイルがグループに追加されます。プロファイル グループを選択しない場合、そのプロファイルはグループの一部ではありません。
  4. メタ グループ]ドロップダウン リストからメタ グループを選択します。「メタ グループの管理」で説明しているカスタム メタ グループを追加できます。
  5. 列グループ]ドロップダウン リストから列グループを選択します。「[イベント]ビューでの列グループの管理」で説明しているカスタム列グループを追加できます。
  6. 結果をフィルタリングするためのクエリを[プレ クエリ]フィールドに入力します。プレ クエリの構文はクエリ ビルダーと同じです。図のプレ クエリは、service = 24,25,109,110,995,143,220,993と呼ばれるメタ グループを使用しています。
  7. プロファイルを使用せずに保存するには[保存]をクリックし、プロファイルを保存してただちに使用するには[保存して適用]をクリックします。
    保存して適用]をクリックすると、選択したプロファイルを適用する前に確認ダイアログが表示されます。バージョン11.2以上では、「プロファイルの管理」ダイアログで入力したプレ クエリが階層リンクに表示されます。
    Profile Pre-Query displayed in the Events view

プロファイルの削除

  1. プロファイルの管理]ダイアログで、名前の横にあるチェックボックスをオンにしてプロファイルを選択します。

    注:ビルトイン プロファイルを削除することはできません。

  2. the Delete optionをクリックします。
    プロファイルを削除するかどうかを確認するメッセージが表示され、プロファイルが削除されます。ツールバーのオプション名がプロファイルに戻り、プロファイルが有効になっていないことが示されます。

アクティブ プロファイルの変更

[ナビゲート]ビューまたは[イベント]ビューに十分な結果または正しい結果が表示されない場合は、アクティブ プロファイルがプレ クエリを適用している可能性があります。プロファイルを使用しない場合は、[プロファイル]ドロップダウン メニューの[プロファイルの非アクティブ化]をクリックします。

別のプロファイルを使用する方法

  1. ナビゲート]ビューまたは[イベント]ビューのツールバーで、[プロファイル]ドロップダウン メニューを開きます。
  2. プロファイル]オプションにマウス ポインターを置くと、使用可能なプロファイルのドロップダウン リストが表示されます。
  3. 使用するプロファイルを選択します。
    そのプロファイル設定が即座に適用されます。

[プロファイルの管理]ダイアログでアクティブ プロファイルを変更する方法

  1. ナビゲート]ビューまたは[イベント]ビューのツールバーで、[プロファイル]>[プロファイルの管理]を選択します。
    [プロファイルの管理]ダイアログが表示されます。
  2. 左側のパネルでプロファイルを選択し、[保存して適用]をクリックします。
    確認ダイアログが表示されます。
  3. はい]をクリックします。
    そのプロファイル設定が即座に適用されます。

プロファイルのインポート

別のサービスからダウンロードした.jsnファイルをアップロードまたはインポートできます。プロファイル グループをエクスポートしてからインポートすると、プロファイルのグループ化が維持されます。

  1. プロファイルの管理]ダイアログで、左側のパネルのツールバーにあるImportをクリックします。
    [プロファイルのインポート]ダイアログが表示されます。
  2. 参照]または[ファイルのアップロード]フィールドをクリックして、コンピューター上のファイルを選択します。
  3. ファイルを選択したら、[アップロード]をクリックします。
    アップロードしたプロファイルが左側のパネルに表示されます。

プロファイルのダウンロード

プロファイルは.jsnファイルとしてダウンロードできます。

  1. プロファイルの管理]ダイアログで、左側のパネルから1つまたは複数のプロファイルを選択します。
  2. 左側のパネルのツールバーでExportをクリックします。
    ダウンロードがすぐに始まります。
You are here
Table of Contents > [ナビゲート]ビューおよび[イベント]ビューでのクエリとデータの処理 > プロファイルを使用したカスタム ビューのカプセル化

Attachments

    Outcomes