Appliance Updater for Oracle 19c fails to update database in RSA Governance & Lifecycle
2 years ago
Article Number
000068821
Applies To
This issue affects RSA Governance & Lifecycle Appliance Updater for Oracle 19c when the following conditions are met:
  • RSA Identity Governance & Lifecycle 7.5.2
  • RSA-provided Oracle 19c database
  • Oracle database is installed in a location other than the default folder /u01
Issue

RSA Governance & Lifecycle Appliance Updater for Oracle 19c may appear to complete successfully but in fact may have failed with some or all of the following symptoms:

  • The Oracle database may fail to start after applying the Appliance Updater for Oracle 19c.
  • The Appliance Updater for Oracle 19c completes but fails to update Oracle Java to the latest version.  Security vulnerability scanners report an older version of Java is present.
  • The Appliance Updater may complete but log errors including but not limited to the following:
Died at /u01/app/19.0.0/grid/crs/install/crspatch.pm line 1185.


To determine whether your RSA Governance & Lifecycle deployment with RSA-provided database may be affected by this issue, check the following from the command line (of the database server):

If the ORACLE_GRID_HOME and ORACLE_HOME have different values you have this issue, for example:

acm-752p08:~ # env | grep ORACLE | grep HOME
ORACLE_GRID_HOME=/u01/app/19.0.0/grid
ORACLE_HOME=/aveksa/u01/app/oracle/product/19.0.0/db_1

 

If the ORACLE_GRID_HOME and ORACLE_HOME values are the same you do not have this issue, for example:

acm-752p08:~ # env | grep ORACLE | grep HOME
ORACLE_GRID_HOME=/u01/app/19.0.0/grid
ORACLE_HOME=/u01/app/oracle/product/19.0.0/db_1

 

Cause

RSA Identity Governance & Lifecycle version 7.5.2 added the ability to install RSA-provided Oracle database instance in a custom folder different than the default location of /u01.  This issue occurs because the installation scripts fail to correctly set the ORACLE_GRID_HOME environment variable to the custom location.  When the Appliance Updater is run, the main Oracle instance may be updated correctly but the GRID components such as Java are not updated.

Resolution

This issue is resolved in the following version:

  • RSA Governance & Lifecycle 8.0.0

See the Notes section.  Customers already impacted must do a fresh install of Oracle database and then migrate the data.

Workaround

Customers affected by this issue should use the following work around.  This must be done once on each of the affected systems. The fix is permanent.

  • Edit the file /home/oracle/setDeployEnv.sh
Modify line 4 and set the value of ORACLE_GRID_HOME to the location of your Oracle instance, for example:
export ORACLE_GRID_HOME=/u01/app/19.0.0/grid
  • Edit the file /etc/init.d/ohasd
Modify line 63 and set the value of ORA_CRS_HOME to the location of your Oracle instance, for example:
ORA_CRS_HOME=/u01/app/19.0.0/grid 
  • Run the Appliance Updater again to complete the portions of the update that failed (the Updater can be run more than once).
Notes

Note that this issue is a problem related to the installation of the 7.5.2 version of the RSA-provided Oracle 19c database either when installed locally as part of the Software Bundle or when installed as a remote database using the database tar package.

  • Customers who installed the 7.5.2 version of RSA-provided Oracle 19c database must use the work around.
  • Customers who installed RSA-provided Oracle 19c database with 7.5.0 are not affected.
  • Customers who installed RSA-provided Oracle 19c database with 8.0.0 are not affected.
  • Customers on 8.0.0 who installed RSA-provided Oracle 19c database originally in 7.5.2 are affected even after the upgrade.
  • Customers on non-RSA provided databases are not affected (cannot use the RSA Appliance Updater)