Backup fails with an error: "Command failed due to timeout of 3600000 milliseconds" on RSA Authentication Manager in 8.4
Last Modified: 2022-05-10
Article Number
Applies To
Product Name: RSA Authentication Manager
Product Version: 8.4
Issue
Starting Database backup..
Backing up database to /opt/rsa/am/backup/staging/database/DB_BACKUP.dump
Initialization OK.
Database command OK: pg_dump
Database command arguments OK.
Database command environment OK.
Command failed due to timeout of 3600000 milliseconds.
Failed to backup database.
Cause
Resolution
a) SSH to RSA AM Primary server(can use putty ssh client tool) and login as rsaadmin.
b)Navigate to /opt/rsa/am/utils
cd /opt/rsa/am/utils
c) Obtain the password for rsa_dba user. Steps are shown in the below example.
rsaadmin@am84p:> cd /opt/rsa/am/utils
rsaadmin@am84p:/opt/rsa/am/utils> ./rsautil manage-secrets -a get com.rsa.db.dba.password
Please enter OC Administrator username: <enter the Operations Console administrator name>
Please enter OC Administrator password: <enter the Operations Console administrator password> com.rsa.db.dba.password:<password_would_be_shown_here>
d) Copy the <password_would_be_shown_here> which is required to access RSA AM internal DB in next step.
e) Navigate to opt/rsa/am/pgsql/bin and connect the DB. Steps are shown in the below example.
rsaadmin@am84p:/opt/rsa/am/utils> cd ../pgsql/bin
rsaadmin@am8-p:/opt/rsa/am/pgsql/bin> ./psql -h localhost -p 7050 -d db -U rsa_dba Password for user rsa_dba: <enter password_would_be_shown_here from step (d) above> psql.bin (9.4.1) SSL connection (protocol: TLSv1.2, cipher: ECDHE-RSA-AES256-SHA, bits: 256, compression: off) Type "help" for help.
db=#
f) Retrieve the timeout value. Query as shown in the below example.
db=# SELECT * FROM rsa_rep.ims_config_value WHERE name LIKE '%auth_manager.backup_restore.timeout.minutes%';
id | instance_id | name | value
----------------------------------+------------------+---------------------------------------------+-------
ee9c45b39a17893b4bfc6b4d618f58a9 | 0000-Global-0000 | auth_manager.backup_restore.timeout.minutes | 60
(1 row)
g) Update the timeout value to 120 minutes as shown in the below query.
db=# UPDATE rsa_rep.ims_config_value SET VALUE = '120' WHERE name LIKE '%auth_manager.backup_restore.timeout.minutes%';
UPDATE 1
h) Now Run the backup again from Operations console.
Note: If the backup fails even after changing the value to 120 min, please increase the value to 180 minutes.
Related Articles
installation failed due to Error 1935 on RSA Authentication Agent 7.3 and 7.4 for Microsoft Windows 82Number of Views CUSD command generates a failure when moving tokens between security domains in RSA Authentication Manager Bulk Administra… 85Number of Views How to disable Ping Internet Control Message Protocol (ICMP) reply on RSA Authentication Manager 8.1 55Number of Views Error: 'Rep name in DB doesn't match host' appears in application log 5Number of Views Unable to attach a replica instance due to a configuration error when enabling replication for the RADIUS server for RSA A… 1.29KNumber of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?