Data Collections and AFX Connectors from/to SQL Server endpoints fail when using the jTDS driver in RSA Identity Governance & Lifecycle
Originally Published: 2015-04-29
Article Number
Applies To
RSA Version/Condition: 6.x, 7.0.x
Issue
SYMPTOMS:
Data Collection
When a SQL Server data collection fails, a test of the same collector fails with the following error in the user interface:
Collector test failed:
com.aveksa.server.runtime.ServerException: Test request failed with response: com.aveksa.server.runtime.ServerException: com.aveksa.sdk.collector.CollectionException: com.aveksa.common.DataReadException: ERROR: Could not get accounts data: . Caused by com.aveksa.common.DataReadException: ERROR: Could not get accounts data: . Caused by java.sql.SQLException: No suitable driver found for jdbc:sqlserver://node,domain.com:1433;databaseName=somedatabase
AFX Connector
When a SQL Server AFX connector fails, the mule_ee.log file ($AFX_HOME/esb/logs/mule_ee.log) has the following error:
Exception followed by:
Caused by: java.lang.UnsupportedClassVersionError: net/sourceforge/jtds/jdbc/Driver :
Unsupported major.minor version 51.0
Cause
For example, the jTDS 1.3.1 driver is compatible with Java 6 but not Java 7.
Resolution
- To install the jTDS driver for use with data collections, see RSA Knowledge Base Article 000034189 -- How to install the jTDS JDBC driver on WildFly for use with Data Collections in RSA Identity Governance & Lifecycle.
- To install the jTDS driver for use with AFX, see RSA Knowledge Base Article 000029641 -- How to install the jTDS JDBC driver for use with AFX in RSA Identity Governance & Lifecycle.
Place the new driver in the lib folder and remove the existing driver. Run these commands as the oracle user.
cp <jTDS 1.2.x driver> $AVEKSA_HOME/jboss-4.2.2.GA/server/default/lib/<jTDS 1.2.x driver> rm <existing SQL Server driver> afx stop acm restart afx start
Notes
This is a legacy Knowledge Base Article and only applies to the listed versions which are no longer actively supported.
RSA does not recommend the continued use of the public domain JTDS driver on current versions of the product. RSA recommends customers use the JDBC driver specific for their database.
Related Articles
Upgrade to RSA Identity Governance & Lifecycle 7.0.2 fails with message "Error occurred when determining the version of th… 204Number of Views Collector Stuck in Data Collection Phase with "Sent Request to Agent Hosting the Collector" 1.59KNumber of Views AFX Server is in a 'Not running' State in the user interface but 'afx status' indicates AFX is running in RSA Identity Gov… 374Number of Views RSA Identity Management and Governance DB logs, task results, task progress are not available on run details of collection… 128Number of Views AFX Server fails to start with java.lang.StackOverflowError errors in the log files after changing the application server … 678Number of Views
Trending Articles
Download RSA SecurID Access Cloud User Event audit logs using Cloud Administration REST API CLU RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide Quick Setup Guide - Passwordless Authentication in Windows MFA Agent for Active Directory Authentication Manager Security Console and Operations Console Inaccessible After Certificate Update Authentication Manager How to Retrieve the LDAPS Certificate and Configure an External Identity Source to Use LDAPS
Don't see what you're looking for?