Database ID Mismatch being reported in the alert log for RSA Identity Governance & Lifecycle
Originally Published: 2018-11-27
Last Modified: 2023-09-25
Article Number
Applies To
RSA Product/Service Type: Enterprise Software
RSA Version/Condition: 7.0.1 and above
Issue
Mon Oct 15 15:54:05 2018
RFS[3]: Assigned to RFS process (PID:7236)
RFS[3]: Database mount ID mismatch [0xa8f4332e:0xa9ec7096] (2834576174:2850844822)
RFS[3]: Destination database ID mismatch [0xa81982fa:0xa296f354] (2820244218:2727801684)
RFS[3]: Not using real application clusters
NOTE:
- The typical location for the AVDB database is /u01/app/oracle/diag/rdbms/avdb/AVDB/trace/.
- The typical filename is alert_AVDB.LOG.
- However, this may be different if RSA Identity Governance & Lifecycle is in remote database configuration (aka DB_REMOTE).
Important Note: Oracle Data Guard is not part of the RSA Identity Governance & Lifecycle out-of-the-box installation package or product.
Cause
Oracle Data Guard mode is implemented by the following Oracle database parameters.
- log_archive_config
- fal_server
- fal_client
- log_archive_dest_n, where one of these parameters are still pointing to the original primary database.
- log_archive_config='DG_CONFIG=(AVDB,AVDBSTBY)'
- fal_server='AVDB'
- fal_client='AVDBSTBY'
- log_archive_dest_2='service=avdbstd lgwr async valid_for=(online_logfiles,primary_role) db_unique_name=avdbstd'
- log_archive_dest_1='location=+dg01 valid_for=(all_logfiles,all_roles) db_unique_name=avdb'
Do not remove the similar setting from the AVDB database, as it is needed for normal operation.
Resolution
- Connect to the database as SYSDBA: # sqlplus / as SYSDBA
- Remove the Oracle Data Guard settings;
SQL> alter system reset log_archive_config scope=spfile sid='*'; SQL> alter system reset fal_server scope=spfile sid='*'; SQL> alter system reset fal_client scope=spfile sid='*'; SQL> alter system reset log_archive_dest_n scope=spfile sid='*';
Where, n is the setting number that has the "service=..." entry
- Exit from SQL*Plus, and restart the AVDB Oracle database.
# acm stopdb # acm startdb
NOTE:
If the entry does not exist, then Oracle will return the following error:
ORA-32010: cannot find entry to delete in SPFILE.
In this case, the error can be ignored.Related Articles
How to resize the Oracle database alert.log for RSA Identity Governance & Lifecycle 106Number of Views Creating an alert view 5Number of Views SSL write error error:14095412:SSL routines:SSL3_READ_BYTES:sslv3 alert bad certificate 81Number of Views Intermittent SSL Exceptions with fatal alert from SOAP calls in Authentication Manager 8.4 Patch 9 52Number of Views Unrecognized characters in syslog payload not allowing alerts to be processed in RSA Security Operations Management 48Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?