Database migration fails in test mode if RADIUS migration is completed first in RSA Authentication Manager 8.1
Originally Published: 2014-11-08
Last Modified: 2022-06-20
Article Number
Applies To
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.0 or 8.1
Issue
- Performing a migration from RSA Authentication Manager 6.1 to Authentication Manager 8.x.
- The RADIUS migration option is completed prior to migrating the Authentication Manager database.
- When performing the Authentication Manager server migration, the option for Test Migration is checked.
- The test migration fails immediately and throws the following error in the /opt/rsa/am/server/logs/migration_basic-<datestamp>/migrationReport.log:
Exception thrown during migration job befc9f71bf01010a1ae6a3d101e9dd75
java.lang.NullPointerException
at com.rsa.authmgr.internal.admin.acemigrate61.impl.task.AgentMigrationTask.linkToRADIUSClientIfNeeded(AgentMigrationTask.java:607)
at com.rsa.authmgr.internal.admin.acemigrate61.impl.task.AgentMigrationTask.processRecord(AgentMigrationTask.java:577)
at com.rsa.authmgr.internal.admin.acemigrate61.impl.task.AgentMigrationTask.executeBatch(AgentMigrationTask.java:134)
at com.rsa.authmgr.internal.admin.acemigrate61.impl.task.AbstractMigrationTask$MigrationTaskTransactionTemplate.doInTransaction(AbstractMigrationTask.java:829)
at org.springframework.transaction.support.TransactionTemplate.execute(TransactionTemplate.java:130)
at com.rsa.authmgr.internal.admin.acemigrate61.impl.task.AbstractMigrationTask.completeTask(AbstractMigrationTask.java:355)
at com.rsa.authmgr.internal.admin.acemigrate61.impl.task.MigrationTaskChainImpl.executeNext(MigrationTaskChainImpl.java:26)
- The /opt/rsa/am/server/logs/imsTrace.log lists following error:
2014-11-04 19:35:30,463, [[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'], (AgentAccessSQL.java:71),
trace.com.rsa.authmgr.internal.admin.common.dal.sql.DataObjectAccessSql, ERROR, <FQDN_of_primary_Authentication_Manager_server>,,,,
Unable to lookup class com.rsa.authmgr.internal.admin.agentmgt.dal.Agentwith ip address: <IP_address_of_primary_Authentication_Manager_server>Cause
Resolution
- Take a backup of the blank database via the Operations Console, if using a hardware appliance, or take a snapshot of the virtual server.
- Skip the test migration option and do a real database migration.
Related Articles
RSA Via L&G Supported OS Required Packages 7Number of Views AFX Server on a WildFly cluster fails to start with 'Cannot connect to RSA Identity Governance and Lifecycle. The watchdog… 241Number of Views Replica Radius server will not synchronize, Primary status is listed as Standalone 281Number of Views ODA (on demand access) token.will not authenticate when connecting thru a Netscaler VPN Gateway 60Number of Views When resetting an out of band (OOB) account password, Access Fulfillment Express (AFX) will always look for full DN to sea… 174Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?