Deleting data from Workflow tables throws error in Identity Governance & Lifecycle
Originally Published: 2018-05-28
Last Modified: 2023-09-22
Article Number
Applies To
RSA Version/Condition: 7.0.2 P03
Issue
DELETE FROM WP_USER_DATA WHERE (PROCI_ID, PROCI_DB) IN (SELECT PROCI_ID,PROCI_DB FROM GTT_WFDATARETENTION_IDS) AND
VAR_NAME IN (SELECT VAR_NAME FROM T_AV_UD_VAR_REMOVE);
V_CUSTOM_MESSAGE := 'Pruned '||SQL%ROWCOUNT||' rows of user data stored in T_AV_UD_VAR_REMOVE';
DATABASE_LOGS.INFO_INFO(G_CTX, IN_RUN_ID, G_PKG_NAME, V_PROC_NAME,V_CUSTOM_MESSAGE); failed with an index key not found error.
SQL Error: ORA-08102: index key not found, obj# 265832, file 12, block 1844690 (2)
08102. 00000 - "index key not found, obj# %s, file %s, block %s (%s)"
Cause: Internal error
Cause
Resolution
alter index WP_USER_DATA_IX01 rebuild;
Related Articles
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?