Email and log file timestamps are incorrect in RSA Identity Governance & Lifecycle
4 years ago
Originally Published: 2018-12-27
Article Number
000040300
Applies To
RSA Product Set: RSA Identiity Governance & Lifecycle
RSA Version/Condition: 7.0.2, 7.1.0
Issue
Timestamps in different areas of the product show incorrectly.
 
  1. For example, viewing the log files (Admin > System > Logs) shows a timestamp value that is ahead by 10-15 minutes:
User-added image
 
The log events in the aveksaServer.log file ($AVEKSA_HOME/wildfly/standalone/log/aveksaServer.log) show the correct time.
 
12/27/2018 15:33:28.549 INFO  (default task-16) [com.aveksa.gui.core.LoginLogout] User logged in: AveksaAdmin::SessionCount=1::UserCount=1
Please refer to RSA Knowledge Base Article 000030327 -- Artifacts to gather in RSA Identity Governance & Lifecycle to find the location of the aveksaServer.log file for your specific deployment if you are on a WildFly cluster or a non-WildFly platform.
 
  1. The display of the RSA Identity Governance & Lifecycle email events under the Admin > Email > Log tab menu shows a Sent/Received time value that is ahead by 10-15 minutes.
User-added image
Cause
The ojdbc7.jar file has a bug converting an oracle timestamp to a java date format.

This is a known issue reported in engineering tickets ACM-89971 and ACM-83684.

Resolution
This issue is resolved in RSA Identity Governance & Lifecycle version 7.1.1 which uses the ojdbc8.jar file.

Note: This issue is fixed in the ojdbc8.jar file. To use this jar file, you must upgrade to an RSA Identity Governance & Lifecycle version that is compatible with the ojdbc8.jar file.
 
Workaround
There are no known workarounds for this issue. Due to the driver dependency this issue is only resolved by upgrading to a version that uses the ojdbc8.jar.