Email and log file timestamps are incorrect in RSA Identity Governance & Lifecycle
Originally Published: 2018-12-27
Article Number
Applies To
RSA Version/Condition: 7.0.2, 7.1.0
Issue
- For example, viewing the log files (Admin > System > Logs) shows a timestamp value that is ahead by 10-15 minutes:
The log events in the aveksaServer.log file ($AVEKSA_HOME/wildfly/standalone/log/aveksaServer.log) show the correct time.
12/27/2018 15:33:28.549 INFO (default task-16) [com.aveksa.gui.core.LoginLogout] User logged in: AveksaAdmin::SessionCount=1::UserCount=1
Please refer to RSA Knowledge Base Article 000030327 -- Artifacts to gather in RSA Identity Governance & Lifecycle to find the location of the aveksaServer.log file for your specific deployment if you are on a WildFly cluster or a non-WildFly platform.
- The display of the RSA Identity Governance & Lifecycle email events under the Admin > Email > Log tab menu shows a Sent/Received time value that is ahead by 10-15 minutes.
Cause
This is a known issue reported in engineering tickets ACM-89971 and ACM-83684.
Resolution
Note: This issue is fixed in the ojdbc8.jar file. To use this jar file, you must upgrade to an RSA Identity Governance & Lifecycle version that is compatible with the ojdbc8.jar file.
Workaround
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