Error when running RSA Authentication Manager 8.x rsautil restore-admin command
Originally Published: 2018-09-06
Last Modified: 2023-11-30
Article Number
Applies To
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.1, 8.2, 8.3
Issue
An example command and output would be:
/opt/rsa/am/utils> ./rsautil restore-admin -o ocadmin -w support1 -u newuserid -p mypasswd!
Exception in thread "main" com.rsa.common.UnexpectedDataStoreException: org.postgresql.util.PSQLException:
ERROR: Unexpected column(s) Updated on table rsa_rep.ims_principal_data: administrator_flag,
Where: SQL statement "update rsa_rep_cover.ims_principal_data_dg DG
PL/pgSQL function tfx_redirtodg_update_ims_principal_data() line 69 at SQL statement
at com.rsa.ims.admin.dal.sql.PrincipalAccessSQL.setAdministratorFlag(PrincipalAccessSQL.java:2143)
at com.rsa.admin.tools.AdminRestorationCLUCommand.addPrincipalData(AdminRestorationCLUCommand.java:395)
at com.rsa.admin.tools.AdminRestorationCLUCommand.execute(AdminRestorationCLUCommand.java:194)
at com.rsa.admin.tools.AdminRestorationCLU.main(AdminRestorationCLU.java:65)
Caused by: org.postgresql.util.PSQLException: ERROR: Unexpected column(s) Updated on table rsa_rep.ims_principal_data: administrator_flag,
PL/pgSQL function tfx_redirtodg_update_ims_principal_data() line 69 at SQL statement
at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2102)
at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1835)
at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:257)
at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:500)
at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:388)
at org.postgresql.jdbc2.AbstractJdbc2Statement.executeUpdate(AbstractJdbc2Statement.java:334)
at com.rsa.ims.admin.dal.sql.PrincipalAccessSQL.setAdministratorFlag(PrincipalAccessSQL.java:2137)
Exception in thread "main" com.rsa.common.SystemException: SQL error occurred while updating records :-ERROR: permission denied for relation ims_principal_admin_role at
com.rsa.admin.tools.AdminRestorationCLUCommand.execute(AdminRestorationCLUCommand.java:216) at com.rsa.admin.tools.AdminRestorationCLU.main(AdminRestorationCLU.java:65)Cause
Resolution
Related Articles
Java exception error during restore of default console certificate on RSA Authentication Manager 8.2 and higher 462Number of Views Impact of missing information on creation of Profiles by Risk Engine 27Number of Views WebService cancelChangeActivity causes activity to stay in Activity State of Open in RSA Identity Governance & Lifecycle 7… 45Number of Views Failed to cleanup RADIUS data when restoring backup from Operations Console of RSA Authentication Manager 8.4.x 243Number of Views Functionality requiring the retrieval of encrypted passwords is failing after a database restore in RSA Identity Governanc… 596Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Manual synchronization introduced in RSA Authentication Manager 8.2 Service Pack 1 patch 6 Quick Setup Guide - Passwordless Authentication in Windows MFA Agent for Active Directory How to verify NTP server synchronization is not working in RSA Authentication Manager 8.x RSA Governance & Lifecycle 8.0.0 Installation Guide
Don't see what you're looking for?