How to create a new ActiveMQ KahaDB for use with AFX in RSA Identity Governance & Lifecycle
Originally Published: 2020-02-26
Last Modified: 2023-10-06
Article Number
Applies To
RSA Version/Condition: 7.0.x, 7.1.x, 7.2.x
Issue
- AFX connectors remain in a Deployed state.
- ActiveMQ will not start.
- Error messages referencing kahadb are in the activemq.log file.
Resolution
- Login as the afx user.
- Stop AFX.
- Navigate to the directory where the ActiveMQ KahaDB database exists.
- Remove the existing KahaDB database.
- Restart AFX. This will create a new KahaDB database.
afx stop cd $AFX_HOME/activemq/data mv kahadb kahadb.old afx start
Related Articles
Running AFX Connectors fail, connectors remain in "Not Deployed" state in RSA Governance & Lifecycle 1.15KNumber of Views How to install Access Fulfillment Express (AFX) for use with RSA Identity Governance & Lifecycle 1.31KNumber of Views RSA Authentication Manager services failed to start after activating a new console certificate 593Number of Views Migrating an RSA Authentication Manager 8.x deployment to a new location with different network settings 321Number of Views Unable to re-use a deleted account name if the account was previously disabled in RSA Identity Governance & Lifecycle 451Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?